Archived

This topic is now archived and is closed to further replies.

tom76

VC++ SOUND HELP!!!

Recommended Posts

tom76    122
Looking at Donuts3D it has a folder in it''s resources called "WAV" where the sound files are. BUT if you try to import a .wav file it goes into a new folder called "WAVE". Copying the donuts3D code across to a new, empty project I''ve tried to import the same .wav files across that are used by the game, but they appear in a new folder called "WAVE". And subsequently my game now has NO SOUND. What is going on here? I''ve tried changing the source code so WAV is WAVE but it makes no difference. Any ideas????? UPDATE I created my own custom type called "WAV" and created blank "WAV"s, copying the hex code from the "WAVE" files into them and renaming, but that doesn;t do anything either!!! "I envy you, who has seen it all" "And I, young sir, envy you, who have yet to see it for the first time..." - Daniel Glenfield 1st October 2001

Share this post


Link to post
Share on other sites
tom76    122

It seems to be my lucky day today - got almost all xmas shopping done, got some cheap pokemon cards - no doubles, 1 rare hologram, and best of all THE SOUND NOW WORKS!!!

Here''s what I did.
In the resources I hit INSERT, called my Custom type "WAV" and created a blank file.
I imported a sound (flamethrower.wav) and it came under "WAVE". I copied the hex code into my blank file, renamed it "FLAMETHROWER" (with the "") and deleted the other file. And it works!!!!

Amazing!

"I envy you, who has seen it all"
"And I, young sir, envy you, who have yet to see it for the first time..."
- Daniel Glenfield
1st October 2001

Share this post


Link to post
Share on other sites