Jump to content
  • Advertisement

Archived

This topic is now archived and is closed to further replies.

capo

fullscreen in tuturial 2

This topic is 6093 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Lo there, I''m experiencing some errors when running the 2nd tuturial in fullscreen. It''s working just fine the way it comes, but if you pass the fullscreen parameter the background you init at start (the whole background) is darker then the parts of the background that you update during the movement of the image. If you don''t experience the same problem, just say so and I''ll threat my gfxcard with some curses. (all you need to change is adding the SDL_FULLSCREEN to the videomode initing, using the source on the page) and thanks for a nice tuturial cone...

Share this post


Link to post
Share on other sites
Advertisement
yes, I have noticed it. It''s like that in windows. In linux everything is fine (at least that''s how I remember it)

The fix is quite easy: replace SDL_HWSURFACE with SDL_SWSURFACE.
and remove SDL_DOUBLEBUF. That should fix everything.


---
cone3d
http://cone3d.gamedev.net
Multitasking - screwing up several things at once.

Share this post


Link to post
Share on other sites
oki =) hate those things you can''t control =)

thanks for a fast answer though...keep up the good work...looking forward to the 3rd tuturial =)

Share this post


Link to post
Share on other sites

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!