Jump to content
  • Advertisement
Sign in to follow this  
ChaseRLewis

Can't run GL_NV_path_rendering extension demos

This topic is 1149 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Advertisement

Strange. Perhaps the demos are run on Intel graphics by default, if you have auto-switching graphics on your laptop. Try setting the default to the NVidia.

 

Or print all available extensions to see if everything looks right.

#include <fstream>
#include <string>
#include <algorithm>
#include <gl/gl.h>

...

wglMakeCurrent(hDC, hGLRC);
{
	std::ofstream file("extensions.txt", std::ios::trunc);
	file << glGetString(GL_VENDOR) << '\n' << glGetString(GL_VERSION) << "\n\n";
	std::string str(reinterpret_cast<const char*>(glGetString(GL_EXTENSIONS)));
	std::replace(str.begin(), str.end(), ' ', '\n');
	file << str;
}

And if it's still missing make sure you have the latest drivers (nvidia.com).

Share this post


Link to post
Share on other sites

Strange. Perhaps the demos are run on Intel graphics by default, if you have auto-switching graphics on your laptop. Try setting the default to the NVidia.

 

Or print all available extensions to see if everything looks right.

#include <fstream>
#include <string>
#include <algorithm>
#include <gl/gl.h>

...

wglMakeCurrent(hDC, hGLRC);
{
	std::ofstream file("extensions.txt", std::ios::trunc);
	file << glGetString(GL_VENDOR) << '\n' << glGetString(GL_VERSION) << "\n\n";
	std::string str(reinterpret_cast<const char*>(glGetString(GL_EXTENSIONS)));
	std::replace(str.begin(), str.end(), ' ', '\n');
	file << str;
}

And if it's still missing make sure you have the latest drivers (nvidia.com).

 

Oh shit, this is exactly what is happening. Didn't think to check it, just assumed it was running on my 980M. Now just need to figure out how to make GLFW force use the 980M.

 

Edit: This was caused my Nvidia's Optimus software for laptops. The solution is super simple, just export a flag on windows. Just add this to your main file with window.h and it will work great.

 

extern "C" 
{
_declspec(dllexport) DWORD NvOptimusEnablement = 0x00000001;
}
Edited by ChaseRLewis

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!