• Advertisement
Sign in to follow this  

Android Studio

This topic is 988 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hi,

 

with the change to Windows 10 I thought it would be a good idea instead of setting up Eclipse together with ADT again instead I am going with Android Studio "for real" this time instead of switching back after a few days, again.

There are a lot of things I hate in IntelliJ but also a few things I like over Eclipse, still I never understand why Google threw away a very powerful IDE for... well... this.

 

Anyway I have a problem right now binding my library project to another project.

 

In Eclipse I could do this:

1.) Rightclick on [library project] -> "Preferences" -> Checkmark at "is Library"

2.) Rightclick on [project using library] -> "Preferences" -> "Add Library" -> Select [library project]

 

Now I am trying to do the same in AndroidStudio but I can't get it to work. I've read through some tutorials and what I did now is importing a "module" and gave it a new module name because "app" was already taken (via: File -> New -> Import Module).

It shows now up in the root folder but I can't use any classes of it in my project.

IntelliJ AndroidStudio keeps marking it as "Cannot resolve symbol '[classname]'"

What am I doing wrong?

 

 

Thank you very much

With Best Regards

Ice

Edited by IceCave

Share this post


Link to post
Share on other sites
Advertisement

Thanks for the link.

I noticed after a while that neither I can add or remove dependencies nor modules. Everytime I closed the project settings screen it made a projectsync and upon reopening it again it was the same as before.

It keeps resetting itself which is really annoying but with the help of your link I could write it manually into the gradle files and now it works, thanks.

 

After that I got mutiple more errors because of gradle problems, different project errors (notice that this was a completly new project, created with the wizard) and after fixing all of these the app didn't even worked because obviously I have to call requestFeature before adding content... or something like that... in an empty activity... sure. Or when IntelliJ refuses to close and I have to forceclose the process, fantastic.

I really have to fight myself finally getting into Android Studio but it is frustrating as it keeps me from work now for several days.

 

Anyway, thank you very much!

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement