Jump to content
  • Advertisement
Sign in to follow this  
Yours3!f

DX12 can't create hardware d3d12 context (only warp)

This topic is 1134 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

hi there,

 

EDIT: oh didnt see that there's a newer driver, installing 355.82 solved it...

 

I tried to run the DX12 hello window graphics sample (https://github.com/Microsoft/DirectX-Graphics-Samples/blob/master/Samples/D3D12HelloWorld/src/HelloWindow/D3D12HelloWindow.cpp), but I can only run it, if I set m_useWarpDevice to true, meaning I can only create a warp device.

 

I have a 64 bit windows 10 installed, I tried to run the sample on a gtx660 using the latest driver (353.62).

Nvidia control panel says I have dx12 runtime and api version, but only feature level 11_0.

DXDiag reports 11.3 directx version, and says that the driver is wddm 2.0 capable, but again, it only lists feature levels up to 11_0.

 

While I can still develop using a warp device, I'll need the hardware device later, so it'd be great if I could solve this smile.png

 

any idea how to fix this? I tried to reinstall the display driver previously, no success.

 

best regards,

Yours3!f

Edited by Yours3!f

Share this post


Link to post
Share on other sites
Advertisement
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!