Jump to content
  • Advertisement
Sign in to follow this  
_void_

[D3D12] Scissor Rectangle Culling

This topic is 1035 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hello,
 
Do you know if scissor rectangle culling has become always enabled in D3D12?
 
In D3D11 you could specify it as part of D3D11_RASTERIZER_DESC. According to the remarks https://msdn.microsoft.com/en-us/library/windows/desktop/dn903899(v=vs.85).aspx, it could be enabled/disabled as part of D3D12_RASTERIZER_DESC. However, it is missing from there in fact.
 
I am getting a warning from the debug layer without setting scissor rect "ID3D12CommandList::DrawIndexedInstanced: Viewport: 0 is non-empty while the coressponding scissor rectangle is empty."
 
Thanks!

?

Share this post


Link to post
Share on other sites
Advertisement
Yeah, that's very weird. I did a grep through the headers, and I couldn't find anything for enabling or disabling the scissor test. I guess that you need to always set it to the viewport size if you don't want anything to be culled.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!