Sign in to follow this  

SDL Image

This topic is 814 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Easy.
  • Uninstall Dev C++
  • Install Visual Studio 2015 Community Edition (free), CodeBlocks (free), Qt (free)
  • Download and extract SDL_Image to your library folder /usr/lib or \lib\cpp\SDL_Image or what have you
  • Add the appropriate include path to the include directories of your project's build configuration
  • Add the appropriate library path to the library directories of your project's build configuration
  • Add SDL_Image.lib/.a/.o to your project's linker configuration
  • Copy SDL_Image.dll and its dependencies to your executable's working directory
And you're done!

Share this post


Link to post
Share on other sites
Nice idea, throwing out your entire toolchain to add a library tongue.png

Why not suggest to install some Linux, so you can install it from the package manager? No need to mess with configurations then.


My usual solution is usually to build such a package from source instead. Download the source code, build the library and install it.

Share this post


Link to post
Share on other sites

Hey Guy, help me install SDL Image on my DEV C++
I tried some ways , but i failed D:
I saw in some tutorials, but it did not work
Thanks!

Under project options-> Directories -> Library Directories add the folder that contains the SDL image library. You'll have to the same thing for the header files but under the Include Directory tab. Should be no different than the steps you followed to use SDL assuming you got SDL to work before trying to add SDL Image.

Then under Parameters in Project Properties in the Linker box add in order
-lmingw32 -lSDL2main -lSDL2 -lSDL2_image

Also, I am not family enough with Dev-C++ to know if using the add Library button means you don't have to set the search path.

I am assuming SDL 2 if not change names accordingly.

Share this post


Link to post
Share on other sites

This topic is 814 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this