Jump to content
  • Advertisement
Sign in to follow this  
DividedByZero

DX11 Shaders not compiling with x64 build target

This topic is 1139 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hi guys,

 

I have a basic DX11 framework that I have created. It works perfectly in an x86 build (VS2015), but the x64 build throws an error at the shader compile stage.

 

The shader I am testing with is bare bones. So I am wondering if there is something different that you need to do in a shader file to make it work in an x64 build?

 

float4 VS_Main( float4 pos : POSITION ) : SV_POSITION
{
    return pos;
}
float4 PS_Main( float4 pos : SV_POSITION ) : SV_TARGET
{
    return float4( 1.0f, 1.0f, 1.0f, 1.0f );
}

 

Thanks in advance :)

Share this post


Link to post
Share on other sites
Advertisement

Always the way isn't it? Right after you post the question you work out the answer.

 

I had neglected to set the working directory for the x64 build.

 

laugh.png

Share this post


Link to post
Share on other sites
I remember one time I worked on a bug for 3 days straight. After exhausting every possibility I posted on here, only to figure it out like 5 min after posting.

Ahh the fun of programming smile.png

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!