• Advertisement
Sign in to follow this  

Eclipse and SFML

This topic is 913 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

So I've been learning C++ and have finally gotten to the point where I'm ready to do graphics. I tried to install SFML and I've followed several tutorials about how to link it properly in Eclipse but I can't get it to work at all. The furthest I can get is where I'm getting undeclared errors instead of unable to resolve ones. Can someone help me figure out what's wrong? I'm using the tutorial code from the SFML website so I know there's nothing wrong with it. Here's some screenshots of my settings if that helps:

 

[spoiler]

fk1ch2.jpg

2efrj14.jpg

 

And a screenshot of the errors I'm getting:
29bycdk.jpg

[/spoiler]

Share this post


Link to post
Share on other sites
Advertisement
Is there some way to see what command-line invocations of g++ your GUI is executing? It might be easier to diagnose the problem from there.

Share this post


Link to post
Share on other sites

The eclipse indexer may not have indexed the sfml files yet, so it gives you these problems.

 

Are you still experiencing problems -> on console <- when you try to compile/build the program?

Share this post


Link to post
Share on other sites
What do you mean by on console? The console window on the bottom of Eclipse? If so its throwing me a bunch of undeclared errors when I try to run it.

Share this post


Link to post
Share on other sites

Yes, the bottom console of Eclipse, it's basically the same as any console compiler output:

 

These error messages are much more useful to us.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement