Jump to content
  • Advertisement
Sign in to follow this  
lonewolff

Sampler state warning

This topic is 977 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hi guys,

 

I am receiving the following warning in my project (on every draw cycle);

 

 

 

The Pixel Shader unit expects a Sampler to be set at Slot 0, but none is bound. This is perfectly valid, as a NULL Sampler maps to default Sampler state. However, the developer may not want to rely on the defaults. [ EXECUTION WARNING #352: DEVICE_DRAW_SAMPLER_NOT_SET]

 

Before I am calling 'draw' I am actually setting the sampler state.

ID3D11SamplerState* sstate = { 0 };
d3dContext->PSSetSamplers(0, 1, &sstate);

Any ideas would be awesome smile.png

 

 

[edit]

Even the debugger seems to agree with me

 

083YHll.png

Edited by DarkRonin

Share this post


Link to post
Share on other sites
Advertisement

Ah, ok. I though setting a nullptr might have been enough to clear the warning 'as a NULL Sampler maps to default Sampler state'.

 

I'll take my time and setup a default sampler :)

 

Thanks for the advice

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!