Jump to content
  • Advertisement

Archived

This topic is now archived and is closed to further replies.

Tamir Raiter

D3DDISPLAYMODE and BackBufferFormat with 8.1

This topic is 6091 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hi, I just installed 8.1 and I have this problem: My engine was doing 40 frames/sec with 8.0, and now it is only 8 frames/sec. Why? same code , same everything... with 8.0 I''m using : D3DPRESENT_PARAMETERS d3dpp; d3dpp.BackBufferFormat = D3DFMT_A8R8G8B8; and I got 40 f/s . same code with 8.1 give me only 8 f/s . I had to change it to D3DFMT_X8R8G8B8 to get only 20 f/s. Does anyone else have the same problems?

Share this post


Link to post
Share on other sites
Advertisement
I had this problem with my ATI Radeon. I had the old drivers installed when I upgraded to DirectX 8.1 and everything got terribly slow (like it was running through the refrast). But since I upgraded to the latest drivers, everything runs perfectly. So I guess your problem is driver related too.

Share this post


Link to post
Share on other sites

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!