Archived

This topic is now archived and is closed to further replies.

Trasparent Mesh Object???

This topic is 5870 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I want to render a mesh object to be semi-transparent, but not to use the texture, only use the default Gouraud shading with light. To have the semi-transparent result, the mesh material is set to be transparent. So the back face and the front face shoud be blended if I turn off z-buffer. But I find it is wrong because the back face is black( the normals of vertices at back face are pointed away from the camera, so the shading result would be black). Then I try another method, first to render the back face with the reversed normals that are pointed inside by the CULL_CW state e.g, followed to render the front face with the outside normals by the CULL_CCW state. The render result will be ok for the transparent. But to be convenience, I should have two same mesh objects, one is inside normal, another is outside. It is bad. Can anybody give me advice how to render the whole mesh to be semi-transparent. Thank you!

Share this post


Link to post
Share on other sites
i usually turn off depth culling and z test , altohugh it works very well for a single object i didn''t test it yet with multiple overlapping objects .....

Share this post


Link to post
Share on other sites