Archived

This topic is now archived and is closed to further replies.

More "8.1 doesn't like me" business

This topic is 5873 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Well, after playing around with it, for no reason whatsoever directx is giving me TERRIBLE framerates. They were 101 or so, now they are 3 or 4. Even if I make it so i am doing nothing on the screen, the frame rate is still 4 at its highest. is anyone else seeing something like this? I could just chalk it up for drivers under Direct X 8.1, but that does me no good since Creative won''t release new drivers and nvidia''s reference drivers wont work.

Share this post


Link to post
Share on other sites
Ok, i am gonna have to say that my computer just don''t like running with Directx 8.1, so to troubleshoot i was going to reinstall 8.0a, which worked fine. (those were the days). Considering I cant just uninstall Directx like a program, and i cant install and older version on top of a newer one, how the hell do i get the old one back in place? Or, one step at a time, how do i get rid of the current one?

Share this post


Link to post
Share on other sites
Don''t even bother trying to remove DX manually, you will destroy your OS.

Have a look in the forums at www.delphi.com/proghall. I remember seeing some links to DirectX uninstallers around the place.

Share this post


Link to post
Share on other sites
tried to reinstall windows, but somehow its still there. blah. Either I gotta format, or wait for the DirectX buster.

I can always just work on some 3d modeling until i get this figured out....

Share this post


Link to post
Share on other sites
Guest Anonymous Poster
yeah i have the same problem, and its pissing me off, i don''t even want to work on my stuff right now, my framerates are like 20 or 30 even when nothing is on the screen, they used to be in the hundreds since i installed 8.1. and the shit that pisses me off is that you can''t uninstall directx, its BS. if anyone knows a solution, please tell me

Share this post


Link to post
Share on other sites
Well, I downloaded the 8.0a sdk again, just for kicks, and of course the problem was still there after i uninstalled 8.1 and put that one on. So, being the rebelious type (well, as rebelious as one can be and still us Microsoft crap), I downloaded the DirectX Buster for 8.0 and used it on 8.1. Not POSITIVE there won''t be any small glitches or bugs after having done this, but by crickey, i installed 8.0a and now my frames are back up to a happy 86. Thanks a lot guys, i am back in the game.

Share this post


Link to post
Share on other sites
GyCot, Try to check if your 3D init is the same as in the SDK Examples.
My engine was doing 40 f/s in DX8.0 and only 8 f/s when I moved to 8.1 . I changed the init process to be the same as the one you have in the "Donut3D" SDK Example and now I''m back with 40 f/s.

Share this post


Link to post
Share on other sites