Sign in to follow this  

[D3D12] Enabling MSAA

This topic is 674 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hello,

 

I'm having issues enabling MSAA in d3d12 and I'm not sure what I'm missing.

 

I have changed the PSO to have a count of 4 and the set the quality to standard ( not sure if necessary ).

    psoDesc.SampleDesc.Count = 4;
    psoDesc.SampleDesc.Quality = DXGI_STANDARD_MULTISAMPLE_QUALITY_PATTERN;

I also have set those 2 variables for the Depth stencil.

 

When running the application like this I get the following error.

 

"the render target sample desc in slot 0 does not match that specified by the current pipeline state.(pipeline state = count 4 quality -1, render target view = count 1 quality 0"

 

As I'm rendering directly to the back buffer so I tried changing the count of swap chain, but that will crash.

 

utpKTO1.png

 

Also, I'm trying to query for the multi-sample support and getting an empty struct. Don't know whats the issue there either.

 

Do anybody know where I'm going wrong?

 

Thanks,

Edited by kretash

Share this post


Link to post
Share on other sites

This topic is 674 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this