Archived

This topic is now archived and is closed to further replies.

Ziphnor

DX 8.1 SDK install failure under WinXP

Recommended Posts

I just bought a used PII-400/160MB ram/8mb ATI rage mobile vid. laptop, which runs WinXP fine, since ive done quite a bit of tweaking, especially by disabling some unused services. Sadly, when i try to install DX 8.1 SDK, the first installer window pops up, configures the installer, it then opens another window, which remains at the task bar, and cant be shown, after that nothing happens. I can shut it down, and then i get an error telling me that the installation failed. On my desktop machine it installed just fine, and that is also running Windows XP, but without any real tweaking. I have also disabled MS-DOS compatible 8.3 file names, could that be it? I have Visual Studio 6.0 SP5 installed on both machines.

Share this post


Link to post
Share on other sites
Guest Anonymous Poster
XP comes with the DX8.1 runtimes, not the SDK which is what i believe Ziphnor was referring to.

Share this post


Link to post
Share on other sites
I am running Windows XP Professoinal and have downloaded and worked with the DirectX SDK for VB and C++, so it does work. Must be your computer then.

Share this post


Link to post
Share on other sites
Thanks for trying to help out, i apologize for not answering before now.
I got finally got it work after enabling ALL the services i had disabled...(grrr...). It was pretty annoying, im not a complete idiot, its not like i disabled the "Windows Installer" service, so how was i to know that whatever service caused this was needed? Anyway, i just installed it and then disabled all the services again.

Looking forward to learn to program DX, even though my C++ skills are a bit shaky(more comfy with Java).

Share this post


Link to post
Share on other sites