• Advertisement
Sign in to follow this  

[C++/D3D11] Problem with texturing a model

This topic is 774 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hello, my problem is that my object is texturing weirdly. Problem accured when I changed something in code.

 

I changed from this : 

http://pastebin.com/Kxdw66BG

to this :

http://pastebin.com/3z3BaD8h

 

I use only use UpdateObjectTransformations() for second skymap, which works perfectly fine, so that shouldn't be problem.

 

this is how texture should be :

http://imgur.com/AqIWKw1

this is how it is :

http://imgur.com/D6tMyWa

Share this post


Link to post
Share on other sites
Advertisement

Kinda hard to tell without seeing the rest of your applications flow control that leads to the invocation of these methods. But, a couple thoughts come to mind. 

 

 

 

m_graphicsClass->m_D3D->GetDevice()

 

Have you debugged your application to see if this is in fact returning a valid handle to your device? Normally I would expect D3DX to throw an exception, but who knows...

Also, did you check after the execution of the D3DX method if m_texture is now an initialized pointer?

 

Just some thoughts

 

Marcus

Share this post


Link to post
Share on other sites

My guess would be that 

ObjectDatas[ArrayCount].texture = m_texture;

should be

ObjectDatas[i].texture = m_texture;

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement