Jump to content
  • Advertisement
Sign in to follow this  
Paulpetk123

Laptop and desktop shows different results.

This topic is 947 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

So I have my engine. I tried to debug it in my desktop, everything seemed alright, text, sprite and objects were drawing. But then I tried to do same on my laptop, for some kind of reason, I can't see sprites and text anymore(everything is alright with objects). What should be my problem?

Share this post


Link to post
Share on other sites
Advertisement

So I have my engine. I tried to debug it in my desktop, everything seemed alright, text, sprite and objects were drawing. But then I tried to do same on my laptop, for some kind of reason, I can't see sprites and text anymore(everything is alright with objects). What should be my problem?

 

 

You made your own engine (I think?), it's pretty much impossible for us to guesstimate what's wrong unless you post some code.

Share this post


Link to post
Share on other sites

 

So I have my engine. I tried to debug it in my desktop, everything seemed alright, text, sprite and objects were drawing. But then I tried to do same on my laptop, for some kind of reason, I can't see sprites and text anymore(everything is alright with objects). What should be my problem?

 

 

You made your own engine (I think?), it's pretty much impossible for us to guesstimate what's wrong unless you post some code.

 

I want you to guys answer what could go wrong when I change computers. What I can check in graphics debugger and others... I'm not asking you to say exactly how to fix it or what my problem is.

Share this post


Link to post
Share on other sites

Give us more details? What rendering APIs do you use. What is the API version on the desktop and on the laptop? Are you sure that there aren't missing resources or wrong paths?

 

Share this post


Link to post
Share on other sites

I'm pretty sure that the OP is using Direct3D 9 and the ID3DXSprite and ID3DXFont interfaces for drawing sprites and fonts, respectively.  Which would be why these items in particular are not working.

Share this post


Link to post
Share on other sites


I'm pretty sure that the OP is using Direct3D 9 and the ID3DXSprite and ID3DXFont interfaces for drawing sprites and fonts, respectively.

 

first place to look would probably be startup resolution. if it selects rez based on HW caps, the rez may change between PC and laptop. if the sprites and fonts dont use device independent code (and dx9 sprite and font APIs are not D.I. code), stuff ends up in the wrong place.

Share this post


Link to post
Share on other sites

So I have my engine. I tried to debug it in my desktop, everything seemed alright, text, sprite and objects were drawing. But then I tried to do same on my laptop, for some kind of reason, I can't see sprites and text anymore(everything is alright with objects). What should be my problem?

 

Honestly there's too many things that could be the issue and you've given us nothing to work with.

 

My suggestion is that you keep at it and use your brain to solve the problem.  Start at the beginning and work your way from there.  Simplify the problem and eliminate variables from the equation.  Step through the code from beginning to end, making sure everything is initialized properly, that the input data is valid, that everything works as expected.  Step through line by line looking at all the variables in the watch window.  Etc.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!