• Advertisement
Sign in to follow this  

Does my game only work when installed using ADB?

This topic is 766 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I recently managed to re-port my game to Android and for me it works without any issues, but everyone else I've given my game to says they just get a white screen.  This isn't making any sense to me.  The difference is that everyone else is downloading it directly from the link below and running it from there while I and one other person installed it through ADB and it works normally.  Why is that?  Does that mean there's something wrong with my code somewhere?

 

For those that want to try it, you can click the link and downloaded here: *nuked; I'll release a more functional build later*

 

This should work on any device running API 10 or greater, and the target sdk version is 16 to keep it compatible with most devices.  Lastly, I don't know if this would have made any difference, but I used Eclipse instead of Android Studio because I never did find any resources on the recent NDK support, and Eclipse just worked unlike everything else for me.  If it does run, then keep in mind that it won't be scaled properly in "Story Mode" because I didn't fix that yet (no need to point that out).  But if you could try it, that would be greatly appreciated.

 

I ran this on my Nexus 7 (2nd Gen, 5.1) and my Droid1 (4.1.1).  Both ran for me, but of course the latter device can't really handle this game too well due to it's age, small screen resolution and low quality touch screen.  I've gotten the white screen on the Droid1 before, but I'd wait it out and the game would work for me after a minute or two.

 

So one thing I did was remove the white screen by adding  this to my style.xml

<item name="android:windowNoTitle">true</item>

When I get a chance, I'll do a splash screen...

 

Any ideas?  Thanks.

 

Shogun

 

EDIT: Just tried downloading it from the net directly on my Nexus 7, it didn't work; just the white screen.  But installing using adb does work...

 

EDIT2: Nevermind, I fixed it.  I forgot to comment out one particular line (Debug.waitForDebugger() to be specific) that causes the device to wait for the debugger to attach itself.  I thought for sure that I did...

Edited by blueshogun96

Share this post


Link to post
Share on other sites
Advertisement
Sign in to follow this  

  • Advertisement