Jump to content
  • Advertisement
Sign in to follow this  
VanillaSnake21

Device creation fails (Win 10, C++)

This topic is 815 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I've recently made some changes to my VS2015 (installed the Windows Phone Developer tools) and for some reason now I'm unable to create a device with a D3D10_CREATE_DEVICE_DEBUG flag, it fails with error

 
<hr1 0x887a002d : The application requested an operation that depends on an SDK component that is missing or mismatched. HRESULT>
 
I have Win10 SDK installed, as a matter of fact I had it installed twice first as a standalone and then when I installed the phone tools, it made me redownload it again. 
 
Is there something I'm missing?
 

Share this post


Link to post
Share on other sites
Advertisement

D3D debug layer stuff isn't installed by default in Win10, you need to install it yourself. https://msdn.microsoft.com/en-us/library/windows/apps/mt210797.aspx

Bigger system updates may require reinstalling it, I remember it stopped working for me after Win10's big november update.

 

Thank you! You're absolutely right, I forgot that I upgraded to 10586 build recently. Everything works fine now :)

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!