Sign in to follow this  
VanillaSnake21

Device creation fails (Win 10, C++)

Recommended Posts

I've recently made some changes to my VS2015 (installed the Windows Phone Developer tools) and for some reason now I'm unable to create a device with a D3D10_CREATE_DEVICE_DEBUG flag, it fails with error

 
<hr1 0x887a002d : The application requested an operation that depends on an SDK component that is missing or mismatched. HRESULT>
 
I have Win10 SDK installed, as a matter of fact I had it installed twice first as a standalone and then when I installed the phone tools, it made me redownload it again. 
 
Is there something I'm missing?
 

Share this post


Link to post
Share on other sites

D3D debug layer stuff isn't installed by default in Win10, you need to install it yourself. https://msdn.microsoft.com/en-us/library/windows/apps/mt210797.aspx

Bigger system updates may require reinstalling it, I remember it stopped working for me after Win10's big november update.

Edited by LandonJerre

Share this post


Link to post
Share on other sites

D3D debug layer stuff isn't installed by default in Win10, you need to install it yourself. https://msdn.microsoft.com/en-us/library/windows/apps/mt210797.aspx

Bigger system updates may require reinstalling it, I remember it stopped working for me after Win10's big november update.

 

Thank you! You're absolutely right, I forgot that I upgraded to 10586 build recently. Everything works fine now :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this