• Advertisement
Sign in to follow this  

Inside out object

This topic is 701 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I am having a weird issue and hoping if someone could give me a hint.

When the application starts the object looks ok but after a few seconds they are inside out.

 

This is the normal behaivior.

[attachment=31946:normal.PNG]

 

This happens after a few seconds when in game.

[attachment=31945:error.PNG]

 

Thank you.

Share this post


Link to post
Share on other sites
Advertisement

What do you do per frame that could affect this? I.e. do you rebuild vertex buffers?

 

If it booted like this I'd just say you have your winding order set to CW when it's meant to be CCW or vice versa.

Share this post


Link to post
Share on other sites

Sorry for not saying this.

 

I load the model before it enters the game loop.

I also tryied with culling and setting the face to CW and CCW and the same effect occurs.

 

I don't do anything particular per frame, just calculating the viewMatrix and transformation matrix.

 

Also I created the app in Java with LWJGL ( latest version ).

Edited by andreialex

Share this post


Link to post
Share on other sites

If someone  is having the same issue, try to disable AMD Gaming Evolved.

I don't know why it does that, yet, but it fixes the issue for now.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement