Jump to content
  • Advertisement
Sign in to follow this  
lonewolff

DX11 D3D11_Create_Device_Debug Question

This topic is 721 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hi Guys,

I have enabled the D3D11 debug device and am running my project in debug mode.

My project is working well and operating as expected. Although I am not seeing any DX11 debug information or warning messages.

#ifdef _DEBUG
	creationFlags |= D3D11_CREATE_DEVICE_DEBUG;
#endif

	unsigned int driver = 0;

	for (driver = 0;driver < totalDriverTypes; ++driver)
	{
		D3D_FEATURE_LEVEL d3dFeatureLevel;
		result = D3D11CreateDeviceAndSwapChain(0, driverTypes[driver], 0, creationFlags, featureLevels, totalFeatureLevels, D3D11_SDK_VERSION, &swapChainDesc, &d3dSwapChain, &d3dDevice, &d3dFeatureLevel, &d3dContext);
		if (SUCCEEDED(result))
			break;
	}
So, either my programming is absolutely flawless (unlikely) or I am missing something.

Any advice is always appreciated.

Share this post


Link to post
Share on other sites
Advertisement
Did you check the d3d control panel in your Windows control panel? It might be that debug is not enabled there for d3d11.

Share this post


Link to post
Share on other sites

When you click in "Edit List" button, you will be able to enter your executable, which in turn will un-gray all those options. DarkRonin, you need to experiment more on your own.

Share this post


Link to post
Share on other sites

Where are you looking for the debug output? Just in case you're looking in your console window / etc, it only appears in visual studio's 'output' window.

 

If you're running Windows 7/8, make sure you've installed the Windows 8.0 SDK.

If you're running Windows 10, you need to separately install the debug layer dlls: http://stackoverflow.com/questions/32809169/use-d3d11-debug-layer-with-vs2013-on-windows-10

Share this post


Link to post
Share on other sites

Where are you looking for the debug output? Just in case you're looking in your console window / etc, it only appears in visual studio's 'output' window.
 
If you're running Windows 7/8, make sure you've installed the Windows 8.0 SDK.
If you're running Windows 10, you need to separately install the debug layer dlls: http://stackoverflow.com/questions/32809169/use-d3d11-debug-layer-with-vs2013-on-windows-10


I actually saw this exact thread yesterday and everything is enabled as per the write up (Win 10 BTW).

And yeah, the VS debug window is where I am looking too. About the only things I ever see are if I have forgotten to release an interface. But prior to this when I was running Windows 8, I used to get a whole gamut of warnings and advice during runtime (for things like mismatched shader inputs etc..).
 

When you click in "Edit List" button, you will be able to enter your executable, which in turn will un-gray all those options. DarkRonin, you need to experiment more on your own.


Your second sentence is a bit presumptuous and offensive. Edited by DarkRonin

Share this post


Link to post
Share on other sites

Let's try and keep it friendly and on-topic here.  :)

 

To get back to the question being asked...have you tried forcing the an error from the debug layer? It should be pretty easy to this: just bind a texture as both a render target and a shader resource simultaneously, or use some incorrect parameters when creating a resource. You can also tell the debug layer to break into the debugger on an error or warning, which will ensure that you're not somehow missing the message:

 

ID3D11InfoQueue* infoQueue = nullptr;
DXCall(device->QueryInterface(__uuidof(ID3D11InfoQueue), reinterpret_cast<void**>(&infoQueue)));
infoQueue->SetBreakOnSeverity(D3D11_MESSAGE_SEVERITY_WARNING, TRUE);
infoQueue->SetBreakOnSeverity(D3D11_MESSAGE_SEVERITY_ERROR, TRUE);
infoQueue->Release();

Share this post


Link to post
Share on other sites
Found it just then. Hiding away in a tab.
 
8MsjxoQ.png

So, in the end nothing needed to be touched in the control panel.

Thanks for your help guys.

(Posted the solution so I don't come back asking the same thing in two years time :))

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!