Advertisement Jump to content
Sign in to follow this  
Angelic Ice

Weird 'attempt to index' Lua Error

This topic is 862 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I was working with Lua and suddenly encountered a weird error:

"attempt to index global 'table' (a nil value)"

which refers to: table.insert(object_table, Object:new{value = 5})

 

The code is the following:

object_table = {}

local Object = {}
Object.__index = Object

function Object:new(result)
    result = result    
    result.value = result
    setmetatable(result, self)
    self.__index = self
    return result
end

function Object:draw ()
	draw_me(value)
end

  
table.insert(object_table, Object:new{value = 5})

This perfectly runs on LuaEdit or any other Lua compiler.

But once I run it, the I receive the named error.

 

All I actually look for is some confirmation that this code should work. If someone has an idea, I would be really thankful hearing it : )

 

Thanks for taking your time to read my thread.

Edited by Angelic Ice

Share this post


Link to post
Share on other sites
Advertisement
Are you running it in your own application that has Lua embedded by any chance? If so, are you being sure to call luaL_openlibs() to open the standard libraries?

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

GameDev.net is your game development community. Create an account for your GameDev Portfolio and participate in the largest developer community in the games industry.

Sign me up!