Jump to content
  • Advertisement
Sign in to follow this  
dave09cbank

Exception when creating Direct2D render target from Directx11 surface

This topic is 623 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

 I'm trying to create Direct2D render target.

This was working fine before but recently it has stopped working and I don't know why & cant seem to figuree out why this has stopped.

I have been on google and trying to figure out exactly why this is happening but cant seem to get any where.

I'm using SharpDx with C# & Directx11

Any suggestions or help would be great.

 

I've attached some images below:

[attachment=33700:Exception_A.PNG]

[attachment=33701:Exception_B.PNG]

 

Share this post


Link to post
Share on other sites
Advertisement

After several days of trying different things i figured it out.

 

It seems the issue was being caused by my graphics card driver. Once i rolled back to a previous driver which i know worked everything worked fine as expected.

 

Note: Using AMG Radeon R9 series card with driver version 21.19.137.1 & Radeon Software version 16.9.2

Edited by dave09cbank

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!