Jump to content
  • Advertisement
Sign in to follow this  
Marat Zahidylin

3ds max 2017 viewport texture quality problem.

This topic is 526 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Advertisement

This happens when Max isn't reading the graphics card correctly.

 

Go to: customize -> preferences -> viewports -> choose driver.

Set it to directX if it's OpenGl or to OpenGl if it is directX ; if the one isn't working the other does.

 

If you set it to directX use a directX shader to get a clear image.

Material/Map -> Materials -> Standard -> DirectX Shader

 

Also set your bitmap size to match the image size, this helps at times.

 

Upping your viewport settings will also improve things a bit, if Max doesn't know what graphics card you are using it sets things low for better performance.

Share this post


Link to post
Share on other sites

Go to: customize -> preferences -> viewports -> choose driver. Set it to directX if it's OpenGl or to OpenGl if it is directX ; if the one isn't working the other does.

Doesn't help.

 

Also set your bitmap size to match the image size, this helps at times.   Upping your viewport settings will also improve things a bit, if Max doesn't know what graphics card you are using it sets things low for better performance.
 

Doesn't help

 

If you set it to directX use a directX shader to get a clear image. Material/Map -> Materials -> Standard -> DirectX Shader

I can't make this shader work.

I have this problem only with black and white textures - looks like low quality texture compression on Android.

 

Share this post


Link to post
Share on other sites
I have this problem only with black and white textures - looks like low quality texture compression on Android.

That is exactly what it is, compression, that is why turning the setting up should have prevented the compression.

 

 

 

I can't make this shader work.

That indicates something wrong with your DirectX driver, you should update your driver and see if it helps.

You need the up to date DirectX 9, 10 or 11.

 

A quick search lead me to this: http://www.scriptspot.com/3ds-max/scripts/nitrous-set-texture-size-limit have you attempted it yet?

Edited by Scouting Ninja

Share this post


Link to post
Share on other sites

A quick search lead me to this:  you attempted it yet?

Didn't help.

 

That indicates something wrong with your DirectX driver, you should update your driver and see if it helps. You need the up to date DirectX 9, 10 or 11.

My version is DirectX 11 (Windows 8.1).
Didn't find redistributable to download.

Scanned by programs: DriverTurbo, DriverUpdated - it did'n find that my DirectX or videocard drivers need update.
 

Share this post


Link to post
Share on other sites

What size is the image, is it a power of two image, what format?

Does it render correctly when you render the image?

 

 

Have you tried:

Views -> Show Material In Viewport As -> Realistic Materials with Maps.

 

Honestly at the moment I am just taking shots in the dark, I have no idea how you are loading the image or what your settings are.

A screenshot of my own setup won't help because all I had to do was switch from OpenGl to DirectX and it was fixed for me.

 

It's one of those small problems with hundreds of reasons and double the solutions.

Edited by Scouting Ninja

Share this post


Link to post
Share on other sites

What size is the image, is it a power of two image, what format?

512*512, jpg

Have you tried: Views -> Show Material In Viewport As -> Realistic Materials with Maps.

Yes

 

Honestly at the moment I am just taking shots in the dark, I have no idea how you are loading the image or what your settings are. A screenshot of my own setup won't help because all I had to do was switch from OpenGl to DirectX and it was fixed for me.   It's one of those small problems with hundreds of reasons and double the solutions.

Yes, at least you have tried to help - thank you.

Share this post


Link to post
Share on other sites

The image correctly scales for me in the browser.

 

I think you realy can narrow this down to OS driver issue, or, some crazy global setting in 3ds max (like some color depth stuff?).

 

But since you say it happens only on black&white pictures, I'd say it is DX drivers.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!