Jump to content
  • Advertisement
Sign in to follow this  
Finoli

FBX SDK: Got a few odd problems..

This topic is 502 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

EDIT:

#1 was due to older formats of FBX.
#2 was a bug in our FBX converter, where a vertex's weights were not properly intialized.
#3 was due to a team-member hardcoding a rotation in order to fix the wrong rotations the objects had when they were previously exported without converting to FbxAxisSystem::DirectX

Got a few problems importing and using data from FBX SDK.

#1

Been working a while with an importer for our game engine. Most things worked as they should with homemade models, however when I e.g. download a random model online and try to export the mesh, FBXSDK does not recognize it as a mesh.

FbxNodeAttribute::EType AttributeType = pCurrentNode->GetNodeAttribute()->GetAttributeType();
if (AttributeType != FbxNodeAttribute::eMesh) continue; //Does never pass unless I made the model myself directly in Maya

Any ideas what might be the cause?

 

#2

When importing our animated meshes we obviously export weights with the vertices. The odd thing is that some vertices do not have normalized weights.
I.e. a vertex's weight for bone1 might be 0.95 and for bone2 0.45 or whatever. It is usually only a few vertices that are affected, but needs a fix regardless.
Any ideas?

 

#3

For testing, we have an animated sphere bouncing up and down in maya. Problem is that in our engine the sphere is bouncing along the floor plane.
I thought this had to do with difference in coordinate systems used, and tried this fix:

//Set to DirectX axis system ///////
   								
FbxAxisSystem SceneAxisSystem = scene->GetGlobalSettings().GetAxisSystem();
FbxAxisSystem OurAxisSystem(FbxAxisSystem::DirectX);				
if (SceneAxisSystem != OurAxisSystem)						
{										
	OurAxisSystem.ConvertScene(scene);					
}

Obviously we are not using the same coordinate system, since the scene is indeed converted. 
However, when animated in our engine, the model winds up quite distorted.. no clue whats going on here.

Feel free to adress as many or as few of these problems as you wish. Any help is greatly appreciated!  :)

If you need more information I will gladly supply it, such as code, graphics debugging etc!

Share this post


Link to post
Share on other sites
Advertisement

There is more than one format of FBX, so it could be that you are using a older format. The FBX files you are downloading is probably not in the format your SDK can use.
If it is the problem you need a FBX converter, I would recommended http://usa.autodesk.com/adsk/servlet/pc/item?siteID=123112&id=22694909

Makes sense.
We're supposed to make our own converter for the course we're taking, but we'll have homemade models soon anyway so it wont be a Big issue.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!