Jump to content
  • Advertisement
lucky6969b

DX11 Could anyone please help me fix my DX11 Renderer?

This topic is 374 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Advertisement

I have my doubts that anyone is going to download ( im not going to download some random zip file from a forum ) and fix your code for you considering you haven't said what the problem is, how you attempted to fix it, or what part you don't understand / is broken. Its a huge time investment considering you haven't invested the time in explaining the problem

Maybe put your code on github or something similar that someone can just browse to safely, and explain your problem in more depth, and you are more likely to get help in my opinion

Share this post


Link to post
Share on other sites

In D3D11_Renderer::BeginFrame set render target:

m_pDeviceContext->OMSetRenderTargets(1, &m_renderTargetView.p, nullptr);

In Triangle::Draw, set primitive topology and vertex-buffer:

deviceContext->IASetPrimitiveTopology(D3D_PRIMITIVE_TOPOLOGY_TRIANGLELIST);
deviceContext->IASetVertexBuffers(0, 1, &m_vertexBuffer.p, &stride, &offset);

See CComPtr with ID3D11RenderTargetView.

Share this post


Link to post
Share on other sites

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!