Jump to content
  • Advertisement
Sign in to follow this  
lucky6969b

3D IDirect3DSurface9 flickers seriously

Recommended Posts

I am wondering why if I use double-buffering in my application, that is setting the back buffer count to one. I get serious flickering just for the IDirect3DSurface9 object. The steps I use to render it is first clear the z buffer, stencil buffer and the render target, then I go into Render2D function first, then do I copy surface, which copies a preloaded managed pool surface to the back buffer, the back buffer is retrieved earlier before. Then I go into the main render function which iterates all game objects, and lastly present it out to the screen, and all over again.

I tried to put the Render2D function within the BeginScene call and outside of it, both result in flickering.

Any ideas how to fix it

Thanks

Jack

Share this post


Link to post
Share on other sites
Advertisement

Double-buffering on it's own is insufficient to prevent flickering; you must also use vsync (set PresentationInterval to D3DPRESENT_INTERVAL_ONE in your D3DPRESENT_PARAMETERS).

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

Participate in the game development conversation and more when you create an account on GameDev.net!

Sign me up!