Jump to content
  • Advertisement
Sign in to follow this  
amadeus12

I'm having trouble for texturing.

This topic is 384 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I'm building my own tool, it's 'jobless.0.3'

I'm parsed objects and write it in my style  and save it.

the model file it self is no problem. I think the mode is problem.

I saw uv coordinates is more than 1.

what kind of sampler state I should use?

this is my format below
vertex
{
p:0.000000,0.100000,4.500000 n:0.000000,1.000000,-0.000000 t:1.000000,0.000000,0.000000 u:0.000000,0.937500;
p:24.000000,0.100000,4.500000 n:0.000000,1.000000,-0.000000 t:1.000000,0.000000,0.000000 u:2.000000,0.937500;
p:0.000000,0.100000,2.890000 n:0.000000,1.000000,-0.000000 t:1.000000,0.000000,0.000000 u:0.000000,1.138750;
p:24.000000,0.100000,2.890000 n:0.000000,1.000000,-0.000000 t:1.000000,0.000000,0.000000 u:2.000000,1.138750;
p:0.000000,0.000000,-2.880000 n:-0.000000,0.099504,0.995037 t:1.000000,0.000000,0.000000 u:-0.000023,1.859195;
p:24.000000,0.000000,-2.880000 n:-0.000000,0.099504,0.995037 t:1.000000,0.000000,0.000000 u:1.999977,1.859195;
p:0.000000,0.100000,-2.890000 n:-0.000000,0.099504,0.995037 t:1.000000,0.000000,0.000000 u:-0.000023,1.871758;
p:24.000000,0.100000,-2.890000 n:-0.000000,0.099504,0.995037 t:1.000000,0.000000,0.000000 u:1.999977,1.871758;
p:24.000000,0.000000,2.880000 n:-0.000000,0.099504,-0.995037 t:1.000000,0.000000,-0.000000 u:2.000005,1.140554;
p:0.000000,0.000000,2.880000 n:-0.000000,0.099504,-0.995037 t:1.000000,0.000000,-0.000000 u:0.000006,1.140554;
p:24.000000,0.100000,2.890000 n:-0.000000,0.099504,-0.995037 t:1.000000,0.000000,-0.000000 u:2.000005,1.127992;
p:0.000000,0.100000,2.890000 n:-0.000000,0.099504,-0.995037 t:1.000000,0.000000,-0.000000 u:0.000006,1.127992;
p:24.000000,0.100000,-4.500000 n:0.000000,1.000000,-0.000000 t:1.000000,0.000000,0.000000 u:2.000000,2.062500;
p:0.000000,0.100000,-4.500000 n:0.000000,1.000000,-0.000000 t:1.000000,0.000000,0.000000 u:0.000000,2.062500;
p:24.000000,0.100000,-2.890000 n:0.000000,1.000000,-0.000000 t:1.000000,0.000000,0.000000 u:2.000000,1.861250;
p:0.000000,0.100000,-2.890000 n:0.000000,1.000000,-0.000000 t:1.000000,0.000000,0.000000 u:0.000000,1.861250;
p:24.000000,0.000000,-2.880000 n:0.000000,1.000000,-0.000000 t:1.000000,0.000000,0.000000 u:2.000000,1.860000;
p:0.000000,0.000000,-2.880000 n:0.000000,1.000000,-0.000000 t:1.000000,0.000000,0.000000 u:0.000000,1.860000;
p:24.000000,0.000000,2.880000 n:0.000000,1.000000,-0.000000 t:1.000000,0.000000,0.000000 u:2.000000,1.140000;
p:0.000000,0.000000,2.880000 n:0.000000,1.000000,-0.000000 t:1.000000,0.000000,0.000000 u:0.000000,1.140000;
}
indice
{
0 1 2 
2 1 3 
4 5 6 
6 5 7 
8 9 10 
10 9 11 
12 13 14 
14 13 15 
16 17 18 
18 17 19 
}
texture
{
diffuse :Road05.jpeg
normal :Road05_NORM.png
}
effect :normal
bufferkey :road
 

look it's 2.0000000 and 1.86

it's more than 1.

and I using default samplerstate which is wrap mode.

I think this is the problem then what adrress mode should I use?

 

this is picture

problem.png

other model fine. it's parsed same parser that i made.

road image only.

problem2.png

Edited by amadeus12

Share this post


Link to post
Share on other sites
Advertisement

You are using clamp addressing, you need wrap addressing. It is a sampler state parameter, you have to set it for u and v ( w is for 3d textures ).

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!