Jump to content
  • Advertisement
GalacticCrew

DX11 DrawIndexed and DrawIndexedInstance takes very long

Recommended Posts

Hello,

I want to improve the performance of my game (engine) and some of your helped me to make a GPU Profiler. After creating the GPU Profiler, I started to measure the time my GPU needs per frame. I refined my GPU time measurements to find my bottleneck.

Searching the bottleneck

Rendering a small scene in an Idle state takes around 15.38 ms per frame. 13.54 ms (88.04%) are spent while rendering the scene, 1.57 ms (10.22%) are spent during the SwapChain.Present call (no VSync!) and the rest is spent on other tasks like rendering the UI. I further investigated the scene rendering, since it takes über 88% of my GPU frame rendering time.

When rendering my scene, most of the time (80.97%) is spent rendering my models. The rest is spent to render the background/skybox, updating animation data, updating pixel shader constant buffer, etc. It wasn't really suprising that most of the time is spent for my models, so I further refined my measurements to find the actual bottleneck.

In my example scene, I have five animated NPCs. When rendering these NPCs, most actions are almost for free. Setting the proper shaders in the input layout (0.11%), updating vertex shader constant buffers (0.32%), setting textures (0.24%) and setting vertex and index buffers (0.28%). However, the rest of the GPU time (99.05% !!) is spent in two function calls: DrawIndexed and DrawIndexedInstance.

I searched this forum and the web for other articles and threads about these functions, but I haven't found a lot of useful information. I use SharpDX and .NET Framework 4.5 to develop my game (engine). The developer of SharpDX said, that "The method DrawIndexed in SharpDX is a direct call to DirectX" (Source). DirectX 11 is widely used and SharpDX is "only" a wrapper for DirectX functions, I assume the problem is in my code.

How I render my scene

When rendering my scene, I render one model after another. Each model has one or more parts and one or more positions. For example, a human model has parts like head, hands, legs, torso, etc. and may be placed in different locations (on the couch, on a street, ...). For static elements like furniture, houses, etc. I use instancing, because the positions never change at run-time. Dynamic models like humans and monster don't use instancing, because positions change over time.

When rendering a model, I use this work-flow:

  1. Set vertex and pixel shaders, if they need to be updated (e.g. PBR shaders, simple shader, depth info shaders, ...)
  2. Set animation data as constant buffer in the vertex shader, if the model is animated
  3. Set generic vertex shader constant buffer (world matrix, etc.)
  4. Render all parts of the model. For each part:
    1. Set diffuse, normal, specular and emissive texture shader views
    2. Set vertex buffer
    3. Set index buffer
    4. Call DrawIndexedInstanced for instanced models and DrawIndexed models

What's the problem

After my GPU profiling, I know that over 99% of the rendering time for a single model is spent in the DrawIndexedInstanced and DrawIndexed function calls. But why do they take so long? Do I have to try to optimize my vertex or pixel shaders? I do not use other types of shaders at the moment. "Le Comte du Merde-fou" suggested in this post to merge regions of vertices to larger vertex buffers to reduce the number of Draw calls. While this makes sense to me, it does not explain why rendering my five (!) animated models takes that much GPU time. To make sure I don't analyse something I wrong, I made sure to not use the D3D11_CREATE_DEVICE_DEBUG flag and to run as Release version in Visual Studio as suggested by Hodgman in this forum thread.

My engine does its job. Multi-texturing, animation, soft shadowing, instancing, etc. are all implemented, but I need to reduce the GPU load for performance reasons. Each frame takes less than 3ms CPU time by the way. So the problem is on the GPU side, I believe.

Share this post


Link to post
Share on other sites
Advertisement

How many triangles and vertices are the models?  Also what hardware (GPU) are you running on?  Finally since you don't mention post processing I'm assuming you're not doing any.  Combine that with the fact that you don't mention a g-buffer so you're likely foward rendering (lighting and potentially shadowing done in the forward pass), I would expect most of your time to be in the draw calls since you're not doing much else.

Share this post


Link to post
Share on other sites

One of the NPC models has 3,339 vertices. The other NPC models will have a similar amount of vertices.

I am running my tests on a Laptop with a GeForce GTX 1050 Ti and Intel(R) HD Graphics 630.

At the moment, I do not use any type of post-processing. My engine can handle topics like Soft Shadowing, but they are all disabled at the moment (because of performance problems on older computers).

Share this post


Link to post
Share on other sites
4 hours ago, GalacticCrew said:

After my GPU profiling, I know that over 99% of the rendering time for a single model is spent in the DrawIndexedInstanced and DrawIndexed function calls

The Draw/Dispatch/Copy/Present functions are the only ones that actually queue up GPU work. The other functions just configure what the next Draw/Dispatch will do. 

If GPU-bound (CPU waiting on GPU situation) you should be spending 100% of your GPU time in those functions. The values that you've got for setting textures etc is just measurement error. 

Share this post


Link to post
Share on other sites

Something bothers me about how you're using the term bottleneck in relation to graphics.  Take a look at this PDF:

http://developer.download.nvidia.com/assets/gamedev/docs/Graphics_Performance_Optimization.pdf

Its old but you should find it useful.  It should help you narrow down your problem.

6 hours ago, GalacticCrew said:

I am running my tests on a Laptop with a GeForce GTX 1050 Ti and Intel(R) HD Graphics 630.

One, use the nvidia control panel program to ensure you're using the 1050ti instead of the integrated intel.  In your other thread you mention having problems on some older PC's what were their specs?

How many models total are you drawing? and as Styves asks how many draw calls?

6 hours ago, GalacticCrew said:

One of the NPC models has 3,339 vertices. The other NPC models will have a similar amount of vertices.

Thats really nothing... confirm the number of vertices and triangles of the other models.

File in case link dies:

Graphics_Performance_Optimization.pdf

edit - also I am not convinced that Vsync is disabled, your results are too close to 16.66ms frame time... make sure the driver isn't forcing vsync.

Edited by Infinisearch

Share this post


Link to post
Share on other sites

Oh you might want to take a look at the older version of the above presentation here:

http://developer.download.nvidia.com/books/HTML/gpugems/gpugems_ch28.html

It explains what 'FB' is.

Also I took a look at the presentation and it does contain some outdated info, some of it you should be able to figure out.  On the other hand there are things you;ll need guidance on so ask... for example it suggests in certain circumstances to use tristrips or fans.  Nowadays indexed triangle lists are what most people use and your best bet for performance.  Of course you should optimize your mesh for both the post transform vertex cache and pre transform cache for best performance for indexed tri lists.  You can find a library to do so here: https://gpuopen.com/gaming-product/tootle/

 

Share this post


Link to post
Share on other sites

I am sorry for my late response, but I was out of office. I did not have the time to read the presentations you linked, but I will read them this weekend. I could solve my performance issue. In my game engine, I check all installed graphics adapter and I use the one with the highest memory and the highest possible Feature Level. As it turned out, my testing laptop gave the same result for all graphics adapter although an Intel HD 630 chip is clearly weaker than my GeForce GTX 1050 Ti chip. I adjusted the system settings and now everything runs smooth.

VSync was turned off. In my main menu, I had around 2 ms per frame, because no 3D models were rendered. When I used a more complex scene in my game, the GPU needed 80 ms per frame. Therefore, I had lag. Using the correct graphics chips, the GPU was reduced by a factor of 10 to around 1 ms per frame in my default case and around 10 ms in very complex scenes.

I will update my FAQ, so all players know about this issue.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!