• Advertisement
  • Popular Tags

  • Popular Now

  • Advertisement
  • Similar Content

    • By Achivai
      Hey, I am semi-new to 3d-programming and I've hit a snag. I have one object, let's call it Object A. This object has a long int array of 3d xyz-positions stored in it's vbo as an instanced attribute. I am using these numbers to instance object A a couple of thousand times. So far so good. 
      Now I've hit a point where I want to remove one of these instances of object A while the game is running, but I'm not quite sure how to go about it. At first my thought was to update the instanced attribute of Object A and change the positions to some dummy number that I could catch in the vertex shader and then decide there whether to draw the instance of Object A or not, but I think that would be expensive to do while the game is running, considering that it might have to be done several times every frame in some cases. 
      I'm not sure how to proceed, anyone have any tips?
    • By fleissi
      Hey guys!

      I'm new here and I recently started developing my own rendering engine. It's open source, based on OpenGL/DirectX and C++.
      The full source code is hosted on github:
      https://github.com/fleissna/flyEngine

      I would appreciate if people with experience in game development / engine desgin could take a look at my source code. I'm looking for honest, constructive criticism on how to improve the engine.
      I'm currently writing my master's thesis in computer science and in the recent year I've gone through all the basics about graphics programming, learned DirectX and OpenGL, read some articles on Nvidia GPU Gems, read books and integrated some of this stuff step by step into the engine.

      I know about the basics, but I feel like there is some missing link that I didn't get yet to merge all those little pieces together.

      Features I have so far:
      - Dynamic shader generation based on material properties
      - Dynamic sorting of meshes to be renderd based on shader and material
      - Rendering large amounts of static meshes
      - Hierarchical culling (detail + view frustum)
      - Limited support for dynamic (i.e. moving) meshes
      - Normal, Parallax and Relief Mapping implementations
      - Wind animations based on vertex displacement
      - A very basic integration of the Bullet physics engine
      - Procedural Grass generation
      - Some post processing effects (Depth of Field, Light Volumes, Screen Space Reflections, God Rays)
      - Caching mechanisms for textures, shaders, materials and meshes

      Features I would like to have:
      - Global illumination methods
      - Scalable physics
      - Occlusion culling
      - A nice procedural terrain generator
      - Scripting
      - Level Editing
      - Sound system
      - Optimization techniques

      Books I have so far:
      - Real-Time Rendering Third Edition
      - 3D Game Programming with DirectX 11
      - Vulkan Cookbook (not started yet)

      I hope you guys can take a look at my source code and if you're really motivated, feel free to contribute :-)
      There are some videos on youtube that demonstrate some of the features:
      Procedural grass on the GPU
      Procedural Terrain Engine
      Quadtree detail and view frustum culling

      The long term goal is to turn this into a commercial game engine. I'm aware that this is a very ambitious goal, but I'm sure it's possible if you work hard for it.

      Bye,

      Phil
    • By tj8146
      I have attached my project in a .zip file if you wish to run it for yourself.
      I am making a simple 2d top-down game and I am trying to run my code to see if my window creation is working and to see if my timer is also working with it. Every time I run it though I get errors. And when I fix those errors, more come, then the same errors keep appearing. I end up just going round in circles.  Is there anyone who could help with this? 
       
      Errors when I build my code:
      1>Renderer.cpp 1>c:\users\documents\opengl\game\game\renderer.h(15): error C2039: 'string': is not a member of 'std' 1>c:\program files (x86)\windows kits\10\include\10.0.16299.0\ucrt\stddef.h(18): note: see declaration of 'std' 1>c:\users\documents\opengl\game\game\renderer.h(15): error C2061: syntax error: identifier 'string' 1>c:\users\documents\opengl\game\game\renderer.cpp(28): error C2511: 'bool Game::Rendering::initialize(int,int,bool,std::string)': overloaded member function not found in 'Game::Rendering' 1>c:\users\documents\opengl\game\game\renderer.h(9): note: see declaration of 'Game::Rendering' 1>c:\users\documents\opengl\game\game\renderer.cpp(35): error C2597: illegal reference to non-static member 'Game::Rendering::window' 1>c:\users\documents\opengl\game\game\renderer.cpp(36): error C2597: illegal reference to non-static member 'Game::Rendering::window' 1>c:\users\documents\opengl\game\game\renderer.cpp(43): error C2597: illegal reference to non-static member 'Game::Rendering::window' 1>Done building project "Game.vcxproj" -- FAILED. ========== Build: 0 succeeded, 1 failed, 0 up-to-date, 0 skipped ==========  
       
      Renderer.cpp
      #include <GL/glew.h> #include <GLFW/glfw3.h> #include "Renderer.h" #include "Timer.h" #include <iostream> namespace Game { GLFWwindow* window; /* Initialize the library */ Rendering::Rendering() { mClock = new Clock; } Rendering::~Rendering() { shutdown(); } bool Rendering::initialize(uint width, uint height, bool fullscreen, std::string window_title) { if (!glfwInit()) { return -1; } /* Create a windowed mode window and its OpenGL context */ window = glfwCreateWindow(640, 480, "Hello World", NULL, NULL); if (!window) { glfwTerminate(); return -1; } /* Make the window's context current */ glfwMakeContextCurrent(window); glViewport(0, 0, (GLsizei)width, (GLsizei)height); glOrtho(0, (GLsizei)width, (GLsizei)height, 0, 1, -1); glMatrixMode(GL_PROJECTION); glLoadIdentity(); glfwSwapInterval(1); glEnable(GL_SMOOTH); glEnable(GL_DEPTH_TEST); glEnable(GL_BLEND); glDepthFunc(GL_LEQUAL); glHint(GL_PERSPECTIVE_CORRECTION_HINT, GL_NICEST); glEnable(GL_TEXTURE_2D); glLoadIdentity(); return true; } bool Rendering::render() { /* Loop until the user closes the window */ if (!glfwWindowShouldClose(window)) return false; /* Render here */ mClock->reset(); glfwPollEvents(); if (mClock->step()) { glClear(GL_COLOR_BUFFER_BIT | GL_DEPTH_BUFFER_BIT); glfwSwapBuffers(window); mClock->update(); } return true; } void Rendering::shutdown() { glfwDestroyWindow(window); glfwTerminate(); } GLFWwindow* Rendering::getCurrentWindow() { return window; } } Renderer.h
      #pragma once namespace Game { class Clock; class Rendering { public: Rendering(); ~Rendering(); bool initialize(uint width, uint height, bool fullscreen, std::string window_title = "Rendering window"); void shutdown(); bool render(); GLFWwindow* getCurrentWindow(); private: GLFWwindow * window; Clock* mClock; }; } Timer.cpp
      #include <GL/glew.h> #include <GLFW/glfw3.h> #include <time.h> #include "Timer.h" namespace Game { Clock::Clock() : mTicksPerSecond(50), mSkipTics(1000 / mTicksPerSecond), mMaxFrameSkip(10), mLoops(0) { mLastTick = tick(); } Clock::~Clock() { } bool Clock::step() { if (tick() > mLastTick && mLoops < mMaxFrameSkip) return true; return false; } void Clock::reset() { mLoops = 0; } void Clock::update() { mLastTick += mSkipTics; mLoops++; } clock_t Clock::tick() { return clock(); } } TImer.h
      #pragma once #include "Common.h" namespace Game { class Clock { public: Clock(); ~Clock(); void update(); bool step(); void reset(); clock_t tick(); private: uint mTicksPerSecond; ufloat mSkipTics; uint mMaxFrameSkip; uint mLoops; uint mLastTick; }; } Common.h
      #pragma once #include <cstdio> #include <cstdlib> #include <ctime> #include <cstring> #include <cmath> #include <iostream> namespace Game { typedef unsigned char uchar; typedef unsigned short ushort; typedef unsigned int uint; typedef unsigned long ulong; typedef float ufloat; }  
      Game.zip
    • By lxjk
      Hi guys,
      There are many ways to do light culling in tile-based shading. I've been playing with this idea for a while, and just want to throw it out there.
      Because tile frustums are general small compared to light radius, I tried using cone test to reduce false positives introduced by commonly used sphere-frustum test.
      On top of that, I use distance to camera rather than depth for near/far test (aka. sliced by spheres).
      This method can be naturally extended to clustered light culling as well.
      The following image shows the general ideas

       
      Performance-wise I get around 15% improvement over sphere-frustum test. You can also see how a single light performs as the following: from left to right (1) standard rendering of a point light; then tiles passed the test of (2) sphere-frustum test; (3) cone test; (4) spherical-sliced cone test
       

       
      I put the details in my blog post (https://lxjk.github.io/2018/03/25/Improve-Tile-based-Light-Culling-with-Spherical-sliced-Cone.html), GLSL source code included!
       
      Eric
    • By Fadey Duh
      Good evening everyone!

      I was wondering if there is something equivalent of  GL_NV_blend_equation_advanced for AMD?
      Basically I'm trying to find more compatible version of it.

      Thank you!
  • Advertisement
  • Advertisement

OpenGL can't get SOIL2 to work with XCODE

Recommended Posts

Getting OpenGL to work with XCODE (on a Macbook) is a wrestling match.  But I've managed to get everything to work except the image managing library SOIL2.

Has anyone had success with this?

I have done the following steps:

  • compiled soil2 with premake and make on the Mac.
  • added all the header files to /usr/local/include/SOIL2
  • added a reference to /usr/local/include to Header Search Paths in Build Settings
  • added a reference to the directory containing the libsoil2-debug.a file to "Link Binary with libraries" under Build Phases
  • added "#include <SOIL2/SOIL2.h> to the program

The error message I get is from the linker, that it can't find the soil2 library.

I tried adding a path to the .a file also to the Library Search Paths, but then I get lots more errors.

After a couple of days going in circles, I'm really stuck.  Had no problem getting soil2 working on the PC under VS.  Any ideas for XCODE?

Share this post


Link to post
Share on other sites
Advertisement

I didn't use SOIL but my main environment is macOS and Xcode, if you set Library Search Path correctly then what error are you getting now? Did you set Other Linker Flags e.g. -lSOIL ?

Share this post


Link to post
Share on other sites
Posted (edited)

 

23 minutes ago, recp said:

I didn't use SOIL but my main environment is macOS and Xcode, if you set Library Search Path correctly then what error are you getting now? Did you set Other Linker Flags e.g. -lSOIL ?

Thanks for the reply!  I'm getting tons of messages of the form "_CFxxxxxx" referenced from: xxxxx in libsoil2-debug.a(SOIL2.o).

So, I'm guessing that it's finding the .a file, but not the stuff that it in turn references?  Would adding a linker flag help?  The soil documentation doesn't mention needing to add one.

By the way, I think soil2 is a static library.

Edited by scottgordon

Share this post


Link to post
Share on other sites
Posted (edited)

If you added .a file by drag and drop Xcode may do it for you. If it is not presents in Linked Frameworks and Libraries then I suggest add that flag. Probably -lSOIL2 if it is libSOIL2.a I would add that. Probably it will fix your issue

Also if you don't set linker flags then there is no reason to set search library path I think. 

EDIT: 
It seems lib name is libsoil2-debug.a so it must be -lsoil2-debug 

Edited by recp

Share this post


Link to post
Share on other sites
11 minutes ago, scottgordon said:

It's already listed in Linked Frameworks and Libraries.

Tried adding the other linker flag, no change.

I tried for you; I downloaded SOIL2 and compiled, linked to my existing project (C99 + ObjectiveC (for UI) ) with drag / drop. I didn't get any linker errors. Also I removed it from Linked Frameworks and Libraries and set it manually in Other Linker Flags then it worked again. 

NOTE: I used `premake4 xcode4` for compiling

You said you got error like _CFxxxxxx. AFAIK CF stands for Apple's CoreFoundation.framework maybe your linker errors are not related to SOIL2 itself? 

Share this post


Link to post
Share on other sites
Posted (edited)

That was a huge hint.  I went back into "Link Binary with Libraries", and added the CoreFoundation framework.  It then built successfully.

It's having other issues, but thank you that looks like it got me past one hump.

Is it normal to have to specify that manually like that?

EDIT:  BTW, a HUGE thank you for actually trying it yourself.  That was very nice of you.

EDIT2:  Got everything else to work too.  recp, I owe you one.

For the benefit of anyone stumbling on this thread, here are all the shenanigans I had to do to get SOIL2 to finally work in XCODE:

  • compiled soil2 with premake and make on the Mac.  I used the command that sets up for make, rather than for xcode, and used "make" rather than xcode to build soil2.  This resulted in a soil2-debug.
  • added all the header files to /usr/local/include/SOIL2 (had to use sudo for this)
  • added a reference to /usr/local/include to Header Search Paths in Build Settings
  • added a reference to the directory containing the libsoil2-debug.a file to "Link Binary with libraries" under Build Phases
  • added the path to the .a file also to the Library Search Paths
  • searched for and added CoreFoundation framework into the "Link Binary with Libraries" (under Build Phases)
  • added "#include <SOIL2/SOIL2.h> to the program
Edited by scottgordon

Share this post


Link to post
Share on other sites

Thanks so much!! I've been trying to link it correctly for the past 3 days with no luck. I couldn't find anything on the web... I was just missing the CoreFoundation lib. Thanks again! :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Advertisement