Jump to content
  • Advertisement
Lastblow

AVIStreamGetFrameOpen returns nullptr...

Recommended Posts

Hey, hey, hey!

Would like to include in my game 2 short avi videos I made in Blender.

Went over NeHe lesson 35, it reads the supplied avi file but when I try to read my avi files,

they both give nullptr for lpbi because of pgf being nullptr on line 106, see below.

There is a similar post on stackoverflow, link here below as well.

Would you, please, update the tutorial, please?

Thank you so very much! ;-)))

PS. Here attached one of the avi files I am trying to read.

	pgf=AVIStreamGetFrameOpen(pavi, NULL);						// Create The PGETFRAME	Using Our Request Mode
	if (pgf==NULL)
	{
		// An Error Occurred Opening The Frame
		MessageBox (HWND_DESKTOP, "Failed To Open The AVI Frame", "Error", MB_OK | MB_ICONEXCLAMATION);
	}

https://stackoverflow.com/questions/39059959/vfw-avistreamgetframeopen-returns-null

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!