Jump to content
  • Advertisement

Graphics Blender: Is this a bad topology?

Recommended Posts

Posted (edited)



I'm new to sculpting. I tried to create the Captain Qwark from the Ratchet and Clank game series. This is the result of 12 hours of sculpting but its also my first time 😛 



I used only the Grab, Smooth, Clay Strips, and Pitch tool since I'm still trying to figure out the rest of the brushes. Also, I did not use dyntopo but the multiresolution modifier. Mostly the model was created using the grab and the smooth tool.


Is it good for a first try? Is the topology meshed messed up? I noticed that using the grap tool was actually meshing a little the shape of the vertices in a way that they won't look very quadratic. I has seen that good modeling in wireframe looks like a lot of very good shaped and defined quads that wrap the entire model something like that



but I'm uncertain how to keep this nice shape of quads when sculpting. When I start with a base shape (using the skin modifier and subdivision surface) I have a nice shape with quads. But the when I'm using the grab tool it messes it.

What am I doing wrong? How can I improve myself?


Thank you.


This is the process I followed:

First I created a skeleton of my model starting only with one vertice and extruding it out.

Then I used a skin, subdivision surface with 1 view and mirror modifiers to create the base of my model. I used only 1 subdivision to keep things simple at first.

Then I applied all the above modifiers and added a new one, a multiresolution modifier with 4 subdivisions.

Then I sculpted the model mostly using the grab and the smooth tool.

Then I boxed model the antenna on his had head (I was trying hours but I could not sculpt this part.) (Edited: LOL do you see that strikeout? Too much hours modeling messed with my head...)

Finally, I applied the multiresolution modifier, added a decimate modifier and subdivided my model from 100,000 vertices to 10,000.


Now I'm trying to UV unwrap my model but it seems impossible to mark seems. I this expected from my bad modeling?


Edited by babaliaris

Share this post

Link to post
Share on other sites
Posted (edited)

This applies to any software. Blender is only a tool.

Your topology looks fine for sculpting but you would never use it in a game or animaton without re-topo. The pro model you show has be  re-topologized.

Edited by fleabay

Share this post

Link to post
Share on other sites

Impressive. That earns a follow. You decimate only when the mesh becomes too heavy. This guy does the next phase similar to my approach, to prepare the asset for uv unwrapping. If you have zbrush, then fine, the above is good. If you don't then the next in blender is this. (sculpt / retopology / uv / texture / rigging / animation )

Edit: I can't wait to see you start with getting this stuff into executable form. It's going to be sweet. :) 

Share this post

Link to post
Share on other sites

Thanks! I'm going to post the results in this post. I'm going to start it from scratch because now with your help I realized something really awesome! I wasn't using dyntopo because I thought that the final mesh for the game would be the sculpted one. But now that I know how retopology works, I will recreate my sculpt using dyntopo (because it's a lot easier to sculpt by using it) and then I will try to do retopology. Well, since I have some experience with box modeling, I guess I will probably manage to do it because that shrinkwrapper modifier looks extremely amazing!!!

Share this post

Link to post
Share on other sites

Here is my high poly sculpt




As you can see its quite good at the head and the torso, but the legs and arms are bad. The reason is that I had a problem with boolean union and sculpting. Maybe you know why is this happening. I created the legs and arms with different objects and then unioned them using the boolean modifier. The result was that, in sculpt mode every time I was using the pitch or worst the smooth tool this was happening:



No matter how much detail I'm adding around that area, when I try to smooth it then it's doing this separation. Why is this happening? Maybe I must use another modifier with the boolean? Also, I have the backface culling enable, maybe the smooth tool is flipping the faces or something because of the boolean union?


Anyways, I will use this to try retopoly for the first time. I was sculpting for 4 hours!!! And youtubers can do much more complicating and detailed things in 1 hour...

Share this post

Link to post
Share on other sites

Xaxa almost made it.




But something went wrong. Do you see these black faces? They appear with backface culling disabled. I had backface culling enabled and I did not notice this disorder. Since with backface culling, everything seems normal, then that must mean that I have double faces which some of them are facing towards the body...

I think the problem occurred when pressing f. Sometimes f creates faces the wrong direction (the normals do not coming towards the camera view as I see the vertices while pressing the f key). I need to be more careful next time... Also I will try to make something simple until I get used to the process because this took me so many hours and I did it wrong too...

Any tips would be awesome (Read both of my last posts to help me with some of my questions).

Share this post

Link to post
Share on other sites

Ah, good morning. Starting over was probably unnecessary, no worries. I was hoping to see someone jump in here but I think we're still predominately programmers. 

Boolean modifications are hit and miss because I believe they don't do the stitch automatically. (Not 100% sure being I don't do that at high poly levels, or ever) So, experimenting with the modifier and two objects, yields the union as expected, the vertices at the intersections appear disconnected but when I switch to sculpt and smooth the seam, I have a single connected mesh. My test, didn't reproduce that separating behavior you described. I would stay away from boolean ops for now. I don't want to discourage experimentation, but you were in a good position with the previous sculpt. No problem.  My guess is that you have not applied the modifier before smoothing. 

Back facing polygons. Edit mode->T shelf (left side)->Shading/UVs Tab  (select all <A key>) Normals:[Recalculate] will unify the hull. Normal directions can be visually verified by Edit mode->N shelf(right side)->Mesh Display:Normals->[Face normals]. The length of the indicator slider is just next to there. 

Doubled up polygons/vertices can be operated on. Edit mode (select all <A key>) Ctrl+v to bring up the vertices menu. Select Remove Doubles. 

There are different schools of thought when it comes to process. Almost never, will a project start from a blank canvas after methods are worked out. A ready made base mesh is usually the starting point. Something fairly close to the shape. But until you have your own personal library and workflow we make do or borrow. baseMesh_M01.zip <--My latest base mesh. You can have that if you want for later to sculpt on if you so choose. 

For now, looking pretty good.  

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Advertisement

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

GameDev.net is your game development community. Create an account for your GameDev Portfolio and participate in the largest developer community in the games industry.

Sign me up!