Jump to content
  • Advertisement
compscistudent

OpenGL Can't get 'make' to work to build SOIL2 library

Recommended Posts

I'm new to graphics and I'm struggling to get the SOIL2 library included.

When I run the 'make' command on Mac for use by Xcode I get the following error:
 

Linking soil2-static-lib

ar: no archive members specified

...

make[1]: *** [../../lib/macosx/libsoil2-debug.a] Error 1

make: *** [soil2-static-lib] Error 2

I'm unsure how to fix this and have been going around in circles for ages! 

Any help would be appreciated

Share this post


Link to post
Share on other sites
Advertisement

hmm.. I'm not sure?

This is my makefile 

 

# GNU Make solution makefile autogenerated by Premake
# Type "make help" for usage help

ifndef config
  config=debug
endif
export config

PROJECTS := soil2-static-lib soil2-shared-lib soil2-test soil2-perf-test

.PHONY: all clean help $(PROJECTS)

all: $(PROJECTS)

soil2-static-lib: 
	@echo "==== Building soil2-static-lib ($(config)) ===="
	@${MAKE} --no-print-directory -C . -f soil2-static-lib.make

soil2-shared-lib: 
	@echo "==== Building soil2-shared-lib ($(config)) ===="
	@${MAKE} --no-print-directory -C . -f soil2-shared-lib.make

soil2-test: soil2-static-lib
	@echo "==== Building soil2-test ($(config)) ===="
	@${MAKE} --no-print-directory -C . -f soil2-test.make

soil2-perf-test: soil2-static-lib
	@echo "==== Building soil2-perf-test ($(config)) ===="
	@${MAKE} --no-print-directory -C . -f soil2-perf-test.make

clean:
	@${MAKE} --no-print-directory -C . -f soil2-static-lib.make clean
	@${MAKE} --no-print-directory -C . -f soil2-shared-lib.make clean
	@${MAKE} --no-print-directory -C . -f soil2-test.make clean
	@${MAKE} --no-print-directory -C . -f soil2-perf-test.make clean

help:
	@echo "Usage: make [config=name] [target]"
	@echo ""
	@echo "CONFIGURATIONS:"
	@echo "   debug"
	@echo "   release"
	@echo ""
	@echo "TARGETS:"
	@echo "   all (default)"
	@echo "   clean"
	@echo "   soil2-static-lib"
	@echo "   soil2-shared-lib"
	@echo "   soil2-test"
	@echo "   soil2-perf-test"
	@echo ""
	@echo "For more information, see http://industriousone.com/premake/quick-start"

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

GameDev.net is your game development community. Create an account for your GameDev Portfolio and participate in the largest developer community in the games industry.

Sign me up!