Archived

This topic is now archived and is closed to further replies.

RAM and linux

This topic is 5848 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I have Mandrake 8.1 and on the login message it gives a little bit of system info (Processer speed, server name, RAM), in that info my amount of RAM is listed incorrectly. It says I have 64 Megs, I really have 256. Does this even matter? How do I change it? Jason Mickela ICQ : 873518 E-Mail: jmickela@sbcglobal.net -Making "alot" a real word one paragraph at a time.-
-Can''t sleep, clown''ll eat me, can''t sleep, clown''ll eat me.

Share this post


Link to post
Share on other sites
Once you log in, pull up a terminal and type

''cat /proc/meminfo''

This will list all your memory information. Check the numbers here instead of their login screen. Look for the line "MemTotal". If that''s not correct, then you have an issue. (bad memory stick possibly)

R.

Share this post


Link to post
Share on other sites
Or, it''s just not being detected properly. You may need to add the boot parameter ''mem=256M'' (I think that''s it...) to your /etc/lilo.conf (assuming you are using LILO).

Share this post


Link to post
Share on other sites
Hard to imagine that Mandrake 8.1 would need that, should be pretty good about memory detection now.

If do try that, you need to edit your lilo.conf.

su up, or log in as root.

1. ''cd /etc''
2. ''cp lilo.conf lilo.old'' // back up your lilo.conf
3. vi/emac or run one of the Gnome edit tools.
4. Find the section that has

image=/boot/vmlinuz
(Not a mandrake user, but pretty sure it''s the same as RHat).

5. Then you''ll need to add the following line

image=/boot/vmlinuz
append="mem=256M" // add this line!

You''ll have other lines under image=, such as label=linux and root=. Don''t mess with these =)

6. Since any changes aren''t carried over until you run lilo,
run ''/sbin/lilo''. Once you''ve run lilo, reboot and check your memory again.

I haven''t had any recent installs of RHat (Rhat and Mandrake are pretty much the same under the hood) not pick up memory lately, so let me know if you have to add mem=256M and it worked.

R.

Share this post


Link to post
Share on other sites
its not a distro issue

its kernel (bios?) level.

use the mem= parameter like others said. 256M may not work, if it doesnt try 255M or 254M

saai

Share this post


Link to post
Share on other sites