Archived

This topic is now archived and is closed to further replies.

Metus

Test my GUI!

Recommended Posts

I want some feedback on my GUI, it''s ugly as hell, but it''s working. Observe the settings.dat that''ll open up the app in the last video configuration http://www.wixner.net/release.zip

Share this post


Link to post
Share on other sites
Worked fine except when I go to full screen I get Set Pixel Format Failed, but I still works, it switches to full screen an I can still see the UI only that I get the msg box with the error.

Am running a p3 800mhz, with 256 megs and gforce2 mx

Share this post


Link to post
Share on other sites
Guest Anonymous Poster
Works Fine too.
i Have a question though... how are you doing the Checking of what''s under the moues cursor? Are you using Picking or Bounds Checking?

Share this post


Link to post
Share on other sites
quote:
Original post by Anonymous Poster
Works Fine too.
i Have a question though... how are you doing the Checking of what''s under the moues cursor? Are you using Picking or Bounds Checking?


well, actually, at the moment, I''m checking the Quad Boundaries. I''ve not looked at Picking yet.. Perhaps that''s an easier way to do this.

Share this post


Link to post
Share on other sites
quote:
Original post by Metus
well, actually, at the moment, I''m checking the Quad Boundaries. I''ve not looked at Picking yet.. Perhaps that''s an easier way to do this.


Hmm... Easier mabye.. but not nessacarily better... with picking it means you have to render twice( though remember to take of all the stuff you don''t need like lighting/textures/etc for the Pick render)... perhaps more Object Orienated if that''s your goal...

Share this post


Link to post
Share on other sites
Im getting a "wglMakeCurrent" error when switching from fullscreen to windowed mode. Also, the mouse pointer disappears in fullscreen.

Win2K, PII 400, 256MB, Voodoo3 3000

Share this post


Link to post
Share on other sites
Guest Anonymous Poster
quote:
Original post by NewDeal
Im getting a "wglMakeCurrent" error when switching from fullscreen to windowed mode. Also, the mouse pointer disappears in fullscreen.

Win2K, PII 400, 256MB, Voodoo3 3000



Well, that''s PROBABLY because of you Voodoo3

Share this post


Link to post
Share on other sites