Archived

This topic is now archived and is closed to further replies.

vfat permissions

This topic is 5849 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hello, I have mounted my windows (vfat) partition to my /mnt/win in Linux. I have no problems reading, writing, or executing as root, but when I go to a group user; I can''t write to my Windows partition, but I can read and execute. I tried settingthe appropriate permissions as the superuser (root) in Konquereor, but it wouldn''t do anything so I went to the konsole and tried chmod, but it gave me a can''t perform operation type of message. This is really annoying, if I want to write to my windows partition I have to log in as root. Is there an option I can change in /etc/fstab? Here is my line from my /etc/fstab that concerns my Windows partition: /dev/hda1 /mnt/win vfat defaults 0 0 Any help would be greatly appreciate, thanks!

Share this post


Link to post
Share on other sites
Try adding the parameter 'uid=501', replacing 501 with whatever UID your non-root user is. I'm sure there's a better way, but this should work.

Edit: You also might want to add 'umask=000'.

Edited by - Martee on December 12, 2001 10:56:48 PM

Share this post


Link to post
Share on other sites
I think I figured it out what I wanted at this website:
http://edge-op.org/grouch/fatperm.html

I'll replay back in less than 15 minutes about whether or not it worked (assuming this doesn't crash my system )

EDIT: THANKS, person above me, I didn't realize you posted till I posted, but you are right it seems; according to that website.

Edited by - Floppy on December 12, 2001 10:58:16 PM

Share this post


Link to post
Share on other sites