Archived

This topic is now archived and is closed to further replies.

balic

Black areas then using Microsofts softwaredriver

Recommended Posts

balic    122
Hi. I am having seriusly problems. I dont know mush about OpenGL but we have a graphic bug in two of our application at my work. We are using OpenGL in MFC and are creating a rendering context from a HDC from a view, and it only appears then I use the software driver from Microsoft. The pixelformat I use is PFD_DRAW_TO_WINDOW | PFD_SUPPORT_OPENGL | PFD_DOUBLEBUFFER I dont know how mush this tells you. The problem is, that then you maximaze the window, the area that once was outside the screen (desktoparea) then the view was created, are not updated (drawn) at all. Like this _________________________ ....................................| <--------X------------->| ___________..................| |_________|..Desktop....| |,,,,,,,,,,,,,,|....................| |,View,,,,,,,|....................| |,,,,,,,,,,,,,,|.<-.MDIClild......| |,,,,,,,,,,,,,,|......................| |---------|.....................| ......................................| ________________________| If the view get as wide as X, the rest of it are blck. Has anyone experience the same problem or seen this before? I would appresiate some advide, or something. /Balic .\n EOF Edited by - balic on December 18, 2001 6:41:35 AM

Share this post


Link to post
Share on other sites
Maximus    124
When you resize the display, use glViewport to tell OpenGL what size to render at.

-----------------------
0wn 0wn 0wn your goat
gently down the pw33n

Share this post


Link to post
Share on other sites
balic    122
I do, and the content are following the window and dissaperaing into the darkness.

Thanks a lot for the comment.

/Balic

.\n
EOF

Share this post


Link to post
Share on other sites