Jump to content
  • Advertisement

Archived

This topic is now archived and is closed to further replies.

Raynale

mouse problem

This topic is 6115 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

hi, i''m pretty new to directx and have a problem with the mouse. i sucessfully created a mouse object and it even runs pretty well. when i move the mouse slowly, my displayed mouse coordinates are ok. BUT: whenever i start to move it faster (to be exact: i move it "normal fast") the counter looses mickeys - or pixels. i tried both ways - relative and absolute coordinates - without success. i''m using dx 6.1 and a ms intellimouse optical. thanks, raynale

Share this post


Link to post
Share on other sites
Advertisement
*shrugs*

For whatever reason, I''ve never been able to get mouse input working through DirectInput. So, I just use the Win32 API functions, GetCursorPos and SetCursorPos. They offer the same performance but don''t require all of that nasty initialization and other nonsense.

Share this post


Link to post
Share on other sites

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!