Archived

This topic is now archived and is closed to further replies.

Jason2Jason

GLUT problems

Recommended Posts

Hi! I just got a book on open GL and it came with the glut libary on its CD. In the book it briefly tells you where to put the files. I did what it said (glut32.dll in windows\system, glut32.lib in the lib fold of my compiler, and the glut.h file in the .h section of my compiler) when I include the header file (glut.h) in my code, i get this linker error: [Linker Error] 'D:\PROGRAM FILES\BORLAND\CBUILDER4\LIB\GLUT32.LIB' contains invalid OMF record, type 0x21 (possibly COFF). (BTW: the D:\ drive is my second Hard Drive). I'm using Borland C++ Builder 4.0 if that helps. Thanks, -J Edited by - jason2jason on January 3, 2002 10:47:11 AM

Share this post


Link to post
Share on other sites
I`m not sure, but C++ builder has library converter from vc++ to cbuilder. Try to search in directory, where compiler is located.

Share this post


Link to post
Share on other sites
I''ve heard of this program but i''m still looking for it!!! Is there a glut lib (and related files) ready to use for borland c++ builder 4, or could someone with bcb convert the lib ( i don''t know how to use the program (if i find it!) )
thx
-j

Share this post


Link to post
Share on other sites
To convert lib you can use the implib and impdef utilities which you can find in the bin of your compiler...
I had the same problem, but now I code with Dev C++, a free compiler, and there is no problem...

Share this post


Link to post
Share on other sites
quote:
Original post by Major
I had the same problem, but now I code with Dev C++, a free compiler, and there is no problem...


I''ve just downloaded Dev C++, but how do you get the glut to work in it?

Share this post


Link to post
Share on other sites
link teh GLut.lib in settings or something
o wait it might be GLut32.lib.....
I dont know.. dont listen to me if you wont, just trying to help





..I still dont get the difference between c and c++...

Share this post


Link to post
Share on other sites
To have the glut to work on it you have to include glut.h...but you also have to link the glut librairies.For that, you go to project->Project Options and choose Load object files: and then choose the libglut32.a file...and it will work.

Share this post


Link to post
Share on other sites