Archived

This topic is now archived and is closed to further replies.

outRider

MSVC debugger

Recommended Posts

outRider    852
I''m having a wierd problem with the debugger. If i hit Go I expect the program will run as if running the exe directly, except within the debugger environment. This has always happened before, but now, ever since I formatted, reinstalled Win2K, and installed Asus'' drivers for my card instead of the Nvidia ref drivers, every time I hit Go it breaks at the first OpenGL call, ChoosePixelFormat(), and gives me the dissassembly of that. I don''t want to step through all that, I did it for about 2 mins straight without getting to the end of that call, I just want it to run through once. I''ve tried every setting in the config menus but still nothing. Does ANYONE ANYWHERE know how to disable that? Yes I''ve tried stepping over and stepping out of and running to cursor, but same thing. Every time I hit that function I get it dissassembled. ------------ - outRider -

Share this post


Link to post
Share on other sites
NickB    146
Has ChoosePixelFormat called an int3 ? have you tried compiling a copy of NeHe''s basecode - which definatelly works - to check this behaviour is a result of the call - not something project dependant ? if you look at the debug output does it specify an error when the program breaks ? are you passing a valid PIXELFORMATDESCRIPTOR structure into it ? the nSize element of the pfd struct MUST be filled in correctly ! is the pointer going in valid ? break-point before the call & check what the structure going in looks like - examine the elements for any strange parameters, check the pointers that go in.

There are a million possibilities...probably not MSVC''s fault (may be a good idea to check out the latest service packs though)

Sorry if this hasn''t been much help - it''s the best I can do

Nick

Share this post


Link to post
Share on other sites
outRider    852
It''s not a problem with the call... everything works fine, its just that it breaks, even though there''s no breakpoint there, whatever I do to get around it. Even if I comment Choose out, it will break when it hits SetPixelFormat(). There''s no error anywhere, it''s probably a setting somewhere, but damned if I know which it is. I''ve installed the latest SP, it never did this before though, I guess I screwed something with the reinstall. Anyone else have any ideas?

------------
- outRider -

Share this post


Link to post
Share on other sites