Archived

This topic is now archived and is closed to further replies.

MrX02

The low frame rate spiral of death

Recommended Posts

Help! I am writing a game with OpenGL. But I can absolutely NOT get frame rates above 12 FPS. My game map only has about 2000 triangles, what could slow it down that much? I have no blending, no game logic(yet), and the map is rendered in a display list before the game is started. I think its my code not my computer, as I am able to play games such as Max Payne with the details set fairly high.

Share this post


Link to post
Share on other sites
Guest Anonymous Poster
What graphics card are you using, what type of window (full screen/windowed) are you using, bit-depth, etc, etc? and how are you displaying the polygons?

Billy

Share this post


Link to post
Share on other sites
make sure you''re performing backface culling and (if possible)
frustrum culling
if you dont enable backface culling, its almost like you''re
rendering 4000 tri''s instead of 2000.

-eldee
;another space monkey;

Share this post


Link to post
Share on other sites
Guest Anonymous Poster
Eldee: What?! Why would it render 4000 instead of 2000 if you don''t have back-face culling enabled? If all 2000 triangles are facing you.. and you have back-face culling enabled... it slows the program down. Either way will display 2000 triangles. Now, if a lot of those aren''t facing you.. then back-face culling can make it less than 2000 displayed, but it will never make it MORE than what you send if you don''t enable it.

Billy

Share this post


Link to post
Share on other sites
He means that on average you will draw half the number of triangles with backface culling on, and therefore drawing 2000 triangles with backface culling off is equivilent to drawing 4000 triangles with backface culling on in terms of the number of triangles actually rendered.

I''m guessing you knew that though...

www.elf-stone.com

Share this post


Link to post
Share on other sites
back to the problem at hand ...

It''s seems too fast for a software rendering problem ... but too slow for hardware!

Trying posting some code in here

Share this post


Link to post
Share on other sites
Thanks for your help! My computer is a an HP desktop with a 900mhz celeron and had a S3 Savage 4 video card when i posted my original question. Since then, i replaced that card with a GeForce2 and my game runs fine. i guess the old card was broken or something...

Share this post


Link to post
Share on other sites