Jump to content
  • Advertisement

Archived

This topic is now archived and is closed to further replies.

Metus

Please test my app

This topic is 6001 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

visit www.wixner.net and download the latest () W3DEngine Binary (0.02) and tell me what you think.

Share this post


Link to post
Share on other sites
Advertisement
I''m so sorry; when i tried my app on another computer; it COULD stop responde during the GLShutdown process.

If this should occur; just kill it with ctrl-alt-del

Share this post


Link to post
Share on other sites
Nice.
Could you post your OS and video card when testing?
There seems to be some problems on NON-nVidia cards and the NeHe shutdown code.

Could someone tell me the VERY-RIGHT-WAY-TO-SHUTDOWN-OPENGL in that case?

Share this post


Link to post
Share on other sites
The right way to shutdown in OpenGL in Win32, is to use the wgl* commands to deselect the rendering context, then delete it.

Once you''ve done that, you can shut down just like any other Win32 program. Look at NeHe''s tutorials for the wgl* commands (they''re usually in the KillGLWindow function)...

iNsAn1tY - the place where imagination and the real world merge...
Try http://uk.geocities.com/mentalmantle

Share this post


Link to post
Share on other sites
quote:
Original post by mkaltner
ran perfect.
no errors on shutdown.
1200+ FPS

ran on Win2k pro.

- Mike


Athlon Thunderbird 900
ATi Radeon 64DDR VIVO
256MB Ram
Windows 2000 Pro

Share this post


Link to post
Share on other sites
I am using a Hercules 3D Prophet II MX 64Mb video card, using NVIDIA''s GeFroce2 MX Chipset. I did not get an error upon quit, though I did get and error when switching from Windowed to Full Screen mode. The error said, "SetPixelFormatFailed". Then when I quit the program when in Full Screen Mode it kept my normal screen in a big ugly resolution, gotta fix that so that you return to the computers normal resolution size.

-Adam

Share this post


Link to post
Share on other sites
Around 3170 fps

The screen is just black though? Except for the text that is...

AthlonXP 1600+, Soltek 75-DRV2 (KT266A), 256 DDR
Leadtek GF3 Ti200 (oc''d at 220/500, with no ramsinks, stock gpu-heatsink with no fan...)

Share this post


Link to post
Share on other sites

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

Participate in the game development conversation and more when you create an account on GameDev.net!

Sign me up!