Archived

This topic is now archived and is closed to further replies.

mikedoty

D3D Overdraw and solutions

Recommended Posts

I have a depth/z buffer put in my D3D, and everything is fine except for the framerate. Let''s say I have four large squares (walls). They are all parralel, so if you''re looking at the one in front, you can''t see the other three. Therefore, the other three shouldn''t be drawn, but it seems that they are being drawn. How can I solve my overdraw problem?

Share this post


Link to post
Share on other sites
If you have a z-buffer enabled, you could render front->back and that will prevent overdraw. You''ll still get a z-test if you''re throwing everything at the card, but z-test should be cheaper than drawing the far wall.

Share this post


Link to post
Share on other sites