Jump to content
  • Advertisement

Archived

This topic is now archived and is closed to further replies.

Al MacInnis

C++ problem

This topic is 5960 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I have a problem on my C++ application : I have Windows 2000, and using SDL libraries. When i use & define 2 SDL_Rect structures, i always get an application fatal error when defining the datas of the first structure. When i declare 2 SDL_Rect structures, and i define only one it runs perfectly.....
  
  SDL_Rect *coords;
  SDL_Rect *blah;

...

coords->x=0;
coords->y=0;
coords->w=100;
coords->h=100;

blah->x=100;
blah->y=100;
blah->w=25;
blah->h=25;

//in this case, the program hangs at the first line (coords->x=0)


coords->x=0;
coords->y=0;
coords->w=100;
coords->h=100;

/*blah->x=100;
blah->y=100;
blah->w=25;
blah->h=25;*/

//in this one, runs perfectly

   
Where's the trick ? Edited by - Al MacInnis on January 30, 2002 8:41:41 AM

Share this post


Link to post
Share on other sites
Advertisement
You have created a pointer but not allocated whatever the pointer is supposed to point to...

Edited by - granat on January 30, 2002 8:52:53 AM

Share this post


Link to post
Share on other sites

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

Participate in the game development conversation and more when you create an account on GameDev.net!

Sign me up!