Archived

This topic is now archived and is closed to further replies.

jobrady

stoopid linking errors!

Recommended Posts

jobrady    122
I know that using a console app can lead to certain "unresolved external symbol" errors, but can anyone tell me why?? I was trying to re-write lesson10(room with bmp textured walls) as a console application(not my choice) and I get "unresolved external symbol _auxDIBImageLoadA@4" when it is linking. Is there any way around this? I really need to figure this out. Thanks, Joe

Share this post


Link to post
Share on other sites
Lord Karnus    122
Are you 100% sure that you linked glaux.lib to your project? I know that some things in gl*.h can get screwy if you don''t include windows.h, but I''ve never tried using gl in a console, so I can''t say for sure.
But it looks just like a missing .lib, probably nothing more.

Share this post


Link to post
Share on other sites
Cobra    122
Yeah.. this is true.. usually its due to a missing lib file.

Either open up project->settings and link it in, or in the file that uses it, add this to the top of your file.

#pragma comment(lib, "glaux.lib")

You can do the same for the other libs you may need, it just searches for the lib on compile time.
Its very useful.

Share this post


Link to post
Share on other sites
jobrady    122
Thanks for making me feel really stupid.
I can''t believe I forgot to link glaux-
I was looking for some complicated problem.
Thanks,
Joe

Share this post


Link to post
Share on other sites