Archived

This topic is now archived and is closed to further replies.

Vegadam

Help Installing Linux

Recommended Posts

Ok, here is the deal.I currently have Windows98 running on my machine, but I want linux. Unfortunetly, everytime my friend installs it it wont take Lilo for some reason. So instead of booting, and giveing me the option of Linux and Windows, it goes strait into windows.... Does anybody know what is wrong?

Share this post


Link to post
Share on other sites
Firstly, try it with a Lilo bootdisk; that''ll ensure that it actually works and it isn''t something wierd with your BIOS like booting past the 1024 cylinder etc.

Next, make sure you install it in /dev/hda in the master boot record at the beginning of the disk. You could install it at the begining of a partition for example if your linux is on /dev/hda2 you could put it on /dev/hda2, but you need a boot loader that supports this, and windows 98''s default boot loader doesn''t (maybe other versions do?). The only boot loaders I know of/had experience with that does that type of loading is FreeBSD''s and GRUB. I''m sure Lilo does this too.

I use GRUB, but they essentially accomplish the same thing.

Hope I helped.

Share this post


Link to post
Share on other sites
It''s possible that LILO was setup with your specific distro to automatically launch the first OS in the lilo.conf file, unless you hold down the left control key while starting up. Then you should be able to choose. Once in Linux do a ''man lilo.conf'' or ''man lilo'' to find out how to change this so that you can choose your OS without having to hold LCTRL down.

rm -rf /bin/laden

Share this post


Link to post
Share on other sites
LILO was installed to the MBR on /dev/hda1. I tried to create a boot disk (we were installing Red Hat 7.0) at the end of the install when it gave us the option to but when I went in to Windows to look at the floopy (because the computer didn''t boot from it when it was in, and yes, the BIOS is setup to boot from the CD-ROM, Floppy, and then HDD) there was no data at all on it, in fact it wasn''t even formatted and I''m pretty sure that Vegadam had it formatted before we used it.

Share this post


Link to post
Share on other sites
quote:
Original post by CmndrM
It''s possible that LILO was setup with your specific distro to automatically launch the first OS in the lilo.conf file, unless you hold down the left control key while starting up. Then you should be able to choose. Once in Linux do a ''man lilo.conf'' or ''man lilo'' to find out how to change this so that you can choose your OS without having to hold LCTRL down.

rm -rf /bin/laden



Really? That sounds rather odd and sorta out there... never the less a posibilty.

Share this post


Link to post
Share on other sites
The only reason I mention that is because that''s actually how I have mine setup. It automatically boots me into linux unless I hold down the CTRL key. That''s good for if you need to restart or the power goes out or something and you want it to automatically boot into your primary OS.

rm -rf /bin/laden

Share this post


Link to post
Share on other sites
Guest Anonymous Poster
is your /boot partition at the beginning of the disk? Most LiLo don''t suffer the 2Gb limit nowadays, but you never know...

As for the boot disk being unformatted, that''s probably because it''s not FAT/FAT32, so Windows can''t read it. It doesn''t mean there''s nothing on the disk . It could just bad sectors though.

Share this post


Link to post
Share on other sites
Could it maybey be something in my BIOS. I tried to do it over again, but unfortunetly, ounce I got to the part where I had to partition it, I had no idea what to do. My friend put it on the first time, and second. But like I said, could it be something in the BIOS?

Share this post


Link to post
Share on other sites