Archived

This topic is now archived and is closed to further replies.

terrain z-sorting problem

This topic is 5780 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hello all, I hope you can help me with this problem...Here how it goes: 1. I have a 2D array representing the height map. 2. Now I draw the terrain using triangle strips. 3. Everything till now is perfect... now when i start moving around the terrain... polygon sorting doesn't work properly... BUT in one case "if i am facing the terrain from the NORTH" moving forward and backward everything is perfect... any other direction sorting gets messy.... Any ideas what I have done wrong? Do I have to do sorting manually? Any suggestions. Thanks in advance, IDispatch Edited by - IDispatch on February 18, 2002 4:54:23 AM Edited by - idispatch on February 20, 2002 4:58:17 AM Edited by - idispatch on February 20, 2002 4:59:04 AM

Share this post


Link to post
Share on other sites
zedzeek, Unfortunately that didn't work either..
Anyway I am posting an image of the problem i am having... hope this can clarify it a bit.


Tha image above shows part of the terrain while I am moving closer to it... You should clearly see the depth problem I am talking about....

Regards,
IDispatch

Edited by - IDispatch on February 19, 2002 2:41:20 AM

Share this post


Link to post
Share on other sites