Archived

This topic is now archived and is closed to further replies.

Fratt

nvidia memory allocation fail

Recommended Posts

hello, i''m using linux, and whenever i want to allocate with glXAllocateMemoryNV it always return null. anyone got an idea ? please help thanx

Share this post


Link to post
Share on other sites
I''m a windows user. So I use wglAllocateMemoryNV instead of glXAllocateMemoryNV. But it is the same function call.

*glXAllocateMemoryNV(sizei size,
float readFrequency,
float writeFrequency,
float priority)

Try to set readFrequency=0; writeFrequency=0; and priority=1.0;
if you want to allocate memory in Video memory.

Try to set readFrequency=0; writeFrequency=0; and priority=0.5;
if you want to allocate memory in System memory.

I hope that this can help you

bondi




Share this post


Link to post
Share on other sites
thanx for your reply Bondi,

i have tested all the combination values for these parameters but it failed anytime !

i haven''t tested it under Windows, and that''s a good idea.
i''ll tell you tomorrow, that maybe a system problem under Linux.

thanx

Fratt

Share this post


Link to post
Share on other sites
In windows I must get the function pointer with wglGetProcAddress("wglAllocateMemoryNV") before I can use wglAllocateMemoryNV.
I don''t know, if it''s nessary in Linux. (use: void (*glXGetProcAddressARB(const GLubyte *))(); )


Share this post


Link to post
Share on other sites
of course it is !
but glXAllocateMemoryNv and glXFreeMemoryNV and others that need adress (as glDrawArrayNV) have got the same adress !!
so i think there is a problem. but where ?

do you know any site that talk about that ? i''m new so, i don''t know much.

thanx a lot !

ps : do you think that asking it to nvidia is a good idea ? or they will ignore me ?

Fratt

Share this post


Link to post
Share on other sites
hello Lev,

thanx for your help here,
AGP is not enabled and i can''t as X doesn''t want to start if i enable it.
need some drivers ?

Fratt

Share this post


Link to post
Share on other sites
hello all of you !

i have succeed !!!
if fact, my kernel didn''t support the AGP. so, i''ve rebuild a new kernel 2.5.1 and now all is OK !
speed increase between twice or 3, and i don''t optimize a lot !
(no nvidia alloc and extension drawing).

before when doing cat /proc/nv/card0 it found a geforce2 mx PCI and now it''s a geforce 2 mx AGP.

AGP is 4x, but SBA is disable: how to enable it ?
and FW is disabled and not supported. how to do it ?

thanx a lot.

i''ll give soon all the sources for such a doing !!

thanx, specially -Lev !

thousand thanx

Fratt

Share this post


Link to post
Share on other sites