Jump to content
  • Advertisement

Archived

This topic is now archived and is closed to further replies.

SpiralGuru3d

DrawIndexedPrimitive(TRI_LIST) fails in Release build

This topic is 5995 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hey guys I have a problem with my release build. I try to maintain it as best as possible, but each time I test it out I get troubles! =) This time, DrawIndexedPrimitive() calls with a tri list seem to fail, well, most of the time, geometry will flicker into view occasionally...very odd. Tri strips...and line lists, indexed or otherwise do not have this problem. If I turn all optiisations off, it does not help. If I "Run with F5" (MS Visual Studio 6) despite there being no debug info, the problem stops, goes away, poof, vanishes!!! =O I was wondering if anybody had seen this little gem before, or if not, whether somebody might have any idea what''s different about running with F5, despite there being no debug info in a Release build...that might cause this problem to go away... I am using a GeForce 2 (Detonator XP 2.3.1.1 drvs), DX8.1 SDK, debug run-time... Thanks! -Scott

Share this post


Link to post
Share on other sites
Advertisement

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!