Archived

This topic is now archived and is closed to further replies.

Tobi-Wan Kenobi

Athlon XP and hardware acceleration jerky?

Recommended Posts

Hi, I''m currently writing a small Direct Draw-game which ran fine on various systems (including a PII233, PII416). Now that I''ve upgraded my system(see details below) to an Athlon 1900+ CPU, I expected the game to run even smoother than before -- but instead it now runs jerky. Only when I turn off the hardware acceleration in the DirectX properties it runs smooth again. - Does this make any sense to you? - What hardware acceleration did I turn off, exactly. Acceleration by the CPU or the the graphics card? - Is there any way to turn off hardware acceleration from within the game if AMD hardware is detected? Thanx alot for any helpful comments! cheers, Tobi PS: some additional data... My new system (game running jerky): AMD AthlonXP1900+, 128MB SD-RAM, GeForce3Ti200 (64MB DDR-RAM), DirectX8 SDK My old system (game ran smooth): PII416, 256MB SD-RAM, Nvidia TNT(16 MB RAM), DirectX8 SDK May the Force be with y''''all!

Share this post


Link to post
Share on other sites
quote:
Original post by Tobi-Wan Kenobi
...128MB SD-RAM, ...256MB SD-RAM...


Hardware acceleration is the graphics card, the cpu is not your problem. I can think of 2 though: 1. Your game uses alot (>128mb) ram and so your new system is swapping from the hd (slow). 2. You said that when you turned acceleration off (meaning the cpu is doing the work instead of your video card) it worked faster, that sounds like a driver problem to me.

Share this post


Link to post
Share on other sites
>> sounds like a driver problem to me.
>>

I dunno -- I tried the manufacturer''s drivers as well as NVIDIA''s latest Detonator drivers(23.11) with the same result.
I also installed my old graphics card, to be sure, and still: the game jerked.

May the Force be with y''''all!

Share this post


Link to post
Share on other sites
>>Did you install the AGP miniport drivers?
>>
Yes I did ... twice.

I experimented some more and came to the conclusion that it must be a driver problem anyway, so you were right, Michalson (after installing my old TNT card once more everything went fine -- until I installed the Detonator drivers which the new card used as well (and which made the game jerk).

I ran a benchmark which analyzed the drivers Direct Draw caps and, among others, came up with the following results:

Blit Capabilities ( Benchmark Tool: Fresh Diagnose )
----------------------------------------------------
Old Card ( TNT with Windows ME''s default drivers )
...
Supports blit stretching Yes
Supports blit to or from system memory Yes
...

( New card: Siluro Gf3 Ti200 with latest Detonator Beta drivers 27.xx )
...
Supports blit stretching No
Supports blit to or from system memory No
...

Since my game makes intense use of these features (page flipping isn''t possible cause it''s running inside a window), I guess the lack of support for those (by any drivers I can possibly use with my graphics-card) makes hardware acceleration fail on my game.

Now, to solve this problem I need to detect support for those features and in case of a negative result, turn off hardware support from within the game -- is that possible?

Cheers,

TWK

May the Force be with y''''all!

Share this post


Link to post
Share on other sites
Alright -- problem solved!

Just get the DD-driver-caps, check them for blitting capabilities and -- if blitting is not suported by the driver -- create a new Direct Draw object which uses no hardware acceleration at all but runs in emulated mode.

Guess the whole problem was sort of a newby thing anyway : )

Anyway, thanx for your help with this everybody!

TWK

May the Force be with y''''all!

Share this post


Link to post
Share on other sites